Prusa MK3S MMU2S keep reseting when connected to Octoprint

What is the problem?

The printer is keep doing some kind of reset of MMU every few minutes when it is connected to Octoprint server. Here is how it looks on the terminal, please have look to logs section

What did you already try to solve it?

I'm fresh after reinstallation of octoprint and octopi 0.17. the issue is the same at Octoprint 1.3.12, 1.4.0 and 1.4.1rc3. I haven't got this issue on my previouse install which was base on octopi 0.16 and Octoprint 1.4.1 rc2 and all before. I use R Pi 3B+ connected through /dev/ttyAMA0
From /boot/cmdline.txt I've make sure to delete console=serial0,115200

Also I've got configured the printer in octoprint as 5 extruders with shared nozzle like described at FAQ

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)
octoprint (1).log (200.3 KB) serial (1).log (33.8 KB) Octoprint_terninal.log (53.7 KB)

Send: M105
Recv: ok T:23.1 /0.0 B:24.0 /0.0 T0:23.1 /0.0 @:0 B@:0 P:24.7 A:31.5
Send: M105
Recv: ok T:23.3 /0.0 B:23.9 /0.0 T0:23.3 /0.0 @:0 B@:0 P:24.7 A:31.9
Recv: \x00echo: 3.9.0-3421
WARNThe received line contains at least one null byte character at position 0, this hints at some data corruption going on
Recv: echo: Last Updated: May 18 2020 17:11:15 | Author: (none, default config)
Recv: Compiled: May 18 2020
Recv: echo: Free Memory: 1675 PlannerBufferBytes: 1792
Recv: echo:Stored settings retrieved
Recv: adc_init
Recv: CrashDetect ENABLED!
Recv: FSensor ENABLED (sensor board revision: 0.3 or older)
Recv: Sending 0xFF
Recv: echo:SD card ok
Recv: echo:busy: processing
Printer seems to support the busy protocol, will adjust timeouts and set busy interval accordingly
Send: M113 S2
Recv: ok
Send: M105
Recv: ok T:22.9 /0.0 B:23.8 /0.0 T0:22.9 /0.0 @:0 B@:0 P:76.5 A:31.4
Recv: MMU => 'start'
Recv: MMU <= 'S1'
Send: M105
Recv: ok T:23.2 /0.0 B:24.3 /0.0 T0:23.2 /0.0 @:0 B@:0 P:25.1 A:31.4
Send: M105
Recv: ok T:23.1 /0.0 B:23.9 /0.0 T0:23.1 /0.0 @:0 B@:0 P:24.6 A:31.7
Recv: MMU => '106ok'
Recv: MMU <= 'S2'
Recv: MMU => '372ok'
Recv: MMU version valid
Send: M105
Recv: ok T:23.2 /0.0 B:24.0 /0.0 T0:23.2 /0.0 @:0 B@:0 P:24.6 A:31.5
Send: M105
Recv: ok T:23.0 /0.0 B:24.1 /0.0 T0:23.0 /0.0 @:0 B@:0 P:24.6 A:31.4
Send: M105
Recv: ok T:23.2 /0.0 B:24.2 /0.0 T0:23.2 /0.0 @:0 B@:0 P:24.7 A:31.5

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Prusa FW 3.9.0 / MMU2S 1.0.6

Hello @Szymon_Klause!

I also had that issue. After I put the firmware again on the printer and MMU, I have no problems. As I searched the forums, I seems to be a issue on the Prusa side.

Unfortunately it didn't solve the issue in my case. I've just completed the Firmware reload at both MK3S and MMU2S. and the sympthom is still the same.

Finaly, I've found reason. Prusa knowleage base article wrote:

The first thing to enable serial connection is to swap ports used by the GPIO (soldered pins) and the internal Bluetooth chip. We need to add a line in the config file on the boot partition.

sudo nano /boot/config.txt

Move the cursor to the very end and add:


and seems that dtoverlay=pi3-miniuart-bt doesn't work well on Raspian Buster. Once I put dtoverlay=disable-bt issue seems to be solved.

1 Like