QIDI X-Plus - Connecting but error on printing

What is the problem?

Octoprint connects to QIDI X-Plus fine and when printing directly i can see temperatures but trying to print or move the X/Y/Z axis throws messages like Recv: //Unknown opt and some garablygook

What did you already try to solve it?

Installed the CBD Fix

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20230402105009.zip (71.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Raspberry Pi 3 B. Running OctoPrint 1.8.7. OctoPi was installed today 4/2/2023.

I see a good number of serial connection errors in your log that indicate possible cable issues.

This poster had a similar issue and found the cause to be the cable they were using. Something to look at.

Good practice on cable use:

  • Use a good quality cable, If you see a lot of noise, get a shielded cable and one with a ferrite filter ring might help as well. I personally have not had any real issues with my cables and noise.
  • Isolate the +5v power line. (this one is important.)

Looking at your log, you have some errors from these 2 plugins:

  • home assistant
  • octoprint_GPX

Might want to turn them off/uninstall while trying to correct this issue. Running in Safe mode would be a good test setup as well.


Thanks for the quick reply. Currently I have just RX and TX connected. Should I have the ground connected as well? Should the 5V be connected?

Yes, you must connect the ground... very important it is the bases of the signal levels.

That was the problem! Connected the ground and all is well. I left the power disconnected.

Thanks very much

Great to here, happy to help. Would be good to mark this with a solution so others can see that it was solved.

:+1: all set. Thanks again

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.