Raspberry 3 A+, can't access octoprint from main pc

What is the problem?

I have two octoprints, and I can't connect to my raspberry pi on my main pc. All other PCs work fine.

What did you already try to solve it?

I've tried manually setting the WIFI band to 2.4 since my router is a dual-band automatic, but there was no option to. Made sure nothing is blacklisted on my router. I'm assuming the pi is connected to the 2.4. I've tried connecting to the hostname through chrome on multiple devices. They all work when connecting to ender3pro2.local. I've switched the same sd card to a different raspberry pi and it's the same issue, so it's possibly an sd card issue? I've also reinstalled my motherboard's wifi's latest drivers as well as restricting it's access to only 2.4ghz.

Have you tried running in safe mode and if so did it solve the issue?

Actually gets worse in safe mode, all of my pcs cant access it.

Additional information about your setup

Octoprint lastest version, using a raspberry pi 3 a+, on an ender 3 pro

I guess you didn't install bonjour on your main pc.
Either install it or try http://ipofthepi / http://octopi

Could you please provide the output of the command line ipconfig/all on a working PC and the failing PC.

Bonjour is not installed on any of my devices. I will install it and get back to you , thank you.

I can't connect via ssh on my main pc, so i dont think i'd be able to do that. I will try it on a working pc.

Would bonjour still be the issue if one out of two of my octoprints are working fine?

Sorry if I wasn't clear, I would like the output of ipconfig /all on the main pc and a working pc. You will have to open a Command Prompt (or PowerShell).

no, I think @b-morgan got the right approach here
run the command and show us the output. It could be a network related problem.

I went ahead and returned the raspberry pi and got a rpi 3 b+. If the issue continues ill send the output of ipconfig. Thank you!