Raspberry Pi Camera Module V2.1 only 640 x 480 mode

Hi,

OctoPrint newbie here.

I have a Raspberry Pi Camera Module V2.1 connected to the latest version of OctoPrint (1.8.4) running on a Raspberry Pi 4B. The camera is attached with a 60cm long ribbon cable.

Although the camera works within OctoPrint the resolution only appears to be 640 x 480 and in 4:3 format. From the specifications of the camera module, I believe it should be possible to go to full 1080p HD quality.

Also, the Camera Settings OctoPrint add-in doesn't seem to be recognising the Pi camera - it's simply listed as 'camera0'.

I have tried, without any success, to modify the octopi.txt file in order to get the camera working at full resolution.

I would really appreciate any help to get my camera working properly.

Sorry but I cannot see where I can access the webcamd.log file.
Please advise and I will forward it if required.

TIA

Please post the content of your octopi.txt file.

If you upload the systeminfo bundle, it should be included automatically in there. Otherwise you can find it in /var/log/webcamd.log.

1 Like

octopi.txt.log (2.9 KB)
@Charlie_Powell ,

Many thanks for pointing me in the right direction to find the webcamd.log file.

As requested I'm uploading this along with my octopi.txt file. In order to upload the octopi.txt file I've renamed it as a .log file.

Basically I've been trying to follow the instructions here to resolve the camera recognition:
https://github.com/The-EG/OctoPrint-CameraSettings/blob/cd14d0939ac087b5a66b9fc8eaa78631d6860e89/docs/setup.md

webcamd.log (74.5 KB)

After further web searches and trials with various settings in my octopi.txt file I've made some progress in getting higher resolution from the Raspberry Pi 2.1 camera.

However there's one issue which I don't seem to be able to correct. The picture from the camera appears to be limited in the number of colours (I think photographers refer to it as 'solarised').
As an example I've attached a screen capture from the camera:

image

Is there anything that I can try before the camera gets thrown out of the window / replaced by a USB webcam?

You can try and increase the bitrate (best done with the camera settings plugin), and if that doesn't work increase the GPU memory through sudo raspi-config.

1 Like

@Charlie_Powell

Many thanks for that - increasing the bitrate to its maximum value (25000000) worked :+1:

I've been absolutely delighted with the OctoPrint system but the camera side (with my Raspberry Cam 2.1) was really bugging me. I {incorrectly} assumed that the official Pi camera would be plug'n'play but now realising that it requires a few 'tweaks'.