Raspi Cam module 2.1 can not change resolution

Camera model
Raspberry Pi Camera Module 2.1 connected to an Raspberry Pi Zero 2 W

What is the problem?
I get an video stream in OctoPrint. But it is only in resolution 640x480.
I can not change it to 1920x1080.

What did you already try to solve it?
I tried severall instructions from different forum posts here:

I changed in octopi.txt parameter: camera_usb_options="-r 1920x1080" but it only seems to zoom in the original 640x480 stream.
I tried also camera_raspi_options="-x 1920 -y 1080 -fps 10 quality 100" but it seems to be ignored.
That's why I swichted camera mode from auto to raspi (camera="raspi") but then no stream at all arrives at OctoPrint

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
Starting up webcamDaemon...

--- Configuration: ----------------------------
cfg_file: /boot/octopi.txt
camera: raspi
usb options: -r 640x480 -f 10
raspi options: -x 1920 -y 1080
http options: -w ./www

Explicitly set USB device:

Found video devices:
config file='/boot/octopi.txt':Starting MJPG-streamer with video device: raspi
<13>Mar 1 14:50:57 root: Starting Raspberry Pi camera
Checking for VL805 (Raspberry Pi 4)...

  • It seems that you don't have VL805 (Raspberry Pi 4).
    There should be no problems with USB (a.k.a. select() timeout)
    Running ./mjpg_streamer -o output_http.so -w ./www -i input_raspicam.so -x 1920 -y 1080
    MJPG Streamer Version.: 2.0
    ERROR: could not find input plugin
    Perhaps you want to adjust the search path with:

    export LD_LIBRARY_PATH=/path/to/plugin/folder

    dlopen: input_raspicam.so: cannot open shared object file: No such file or directory
    Done bringing up all configured video devices
    Scanning again in two minutes

Additional information about your setup (OctoPrint version, OctoPi version, ...)
OctoPrint version : 1.8.6
OctoPi version : 1.0.0

I believe most of the topics you mentioned probably were from Buster (or earlier) based operating systems (OctoPi 0.18.0 is based on Buster). OctoPi 1.0.0 is based on Bullseye and the camera support is entirely different.

See my suggestion in https://community.octoprint.org/t/raspberry-pi-camera-setup-in-latest-stable-octopi-build/50231/4. I got my RPi camera V2 working with the information in the topic mentioned there.

OK thx. I'll give that a try

thanks a lot. Your hint worked for me. :smiley:
The new video plugin seems to be so much better than the old one.
Hope it will be part of the official OctoPi image soon.