Raspberry Pi Camera V2 Not working on Raspberry pi 3 B

Camera model

Raspberry pi Cam v2

What is the problem?

Okay, so I am very new to Octoprint and I set it all up and my camera would not show up and I get the error Webcam steam not loaded so I ssh into my raspberry pi and I tried the command `libcamera-hello --list-cameras' and it said that there is no camera detected.

What did you already try to solve it?

I have looked in the boot config and found nothing wrong. I have also tried installing the new camera stack and I have made sure that the ribbon cable is plugged in so the pins of it and the raspberry pi are touching and the same thing on the camera I have also tried my extension ribbon cable that I bought for it and It did not work either.

Have you tried running in safe mode?

No, I don't know how

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20240410170312.zip (35.6 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I have the Ender 3 3d, Octoprint version at the moment I am still running the new camera stack and it is 1.9.3 and octo pi vertion is 1.0.0

This is critical for diagnosing issues with the camera stack. It shows what the streaming service is doing. Please share it

Here it is sorry.
octoprint-systeminfo-20240410170312.zip (35.6 KB)

I updated my ticket

I just skimmed over your Logs and found this:

“2024-04-09 19:35:18,565 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.”

in “octoprint.log”.