Raspberry Pi Camera V2 Settings?

once was good enough, your new settings worked 1 million percent for me :slight_smile:
i cant thank you enough, both of you for your help here, greatly appreciated.
if your into video games old and new and are ever in leeds, come by my work (ARCADE CLUB LEEDS) and ill be sure to let you both in for some gaming :slight_smile:

now to check my camera resolution
can i do this from within octoprint, or do i need to ssh into the pi to do this ?

thanks again


1 Like

That looks AWESOME! If I'm ever in the area, I will be sure to stop by.

Also, click 'Switch to Custom Page' for a better experience. The RPI cam settings need to be applied in a particular order, and some settings rely on other settings to work properly. The custom page has all (most??) of that stuff built in.

1 Like

when i click switch to custom page i get an error message lol

there is no custom control for your webcam at the moment


Prusa MK3S
is not in your drop down list of printer profiles mate :slight_smile:

Do me a favor and go to this link:


Paste in the results at gist.github.com and create an issue here. Don't worry about filling out the template, but give it a good title and a brief description.

I can make the custom page work probably, but it will take an update. Now's the time.

1 Like

ok i posted the glist as DAVE11674 settings
the other page not sure what ive to do lol
i pasted the results in there also and named it DAVE11674 raspicam no custom page


You pasted the input.json into the issue, which is fine. Gist is a place you can post relatively large files, which keeps the issue clean. input.json isn't so large that it's a big deal, but you can imagine what it would look like if one pasted in a 100MB log file :slight_smile:

Anyway, I'm going to take a look at this soon, and will continue the discussion over on Github.com. Thanks for helping to improve the plugin!

1 Like

So many quarters and I parted ways because of these as a kid. (No regrets.)

1 Like


hi guys, ok im pretty much just about to start a octolapse

but my focus seems a little out on the object i placed on the center of the bed
i cant for the life of me find the focus control lol

so i figued to twist the lense of the camera and got it focused

now on to and other problem
when i do octolapse and its set to capture on Z change
well its taking a screenshot
but its not changing layer
Z is not stepping up to the next level and just tries to print layer 2 where layer 1 is
hope your following me lol


The Pi NoIR V2 comes out-of-the-box with infinity focus. As you discovered, twisting the lens will change this.

You might want to search some of the other forum entries on here for Octolapse settings.

ok thanks mate

on another level

i disabled the octolapse plugin and the fault has gone away, but kinda defeats my purpose of wanting to do teh timelapse videos lol


You can still do Timelapse, just not the fancy ones that OctoLapse can do.

nooooooooooooooooo lol
i must have the nice fancy smooth ones :slight_smile:

i will erase and reinstall the octolapse plugin

see if that does anything for me :slight_smile:



The Octolapse plugin author is active both in these forums and on [github].(https://formerlurker.github.io/Octolapse/)
Open an issue there and I'm sure some solution can be found.

1 Like

It's not changing Z!??? ouch... Can you create an issue here? I've never heard of this before, so I'm very interested in figuring it out.

Please be sure to export your settings (gear icon on the octolapse tab->export settings), and supply a sample gcode file. I'll run it through the debugger and will let you know what I find.

ok will try this again now for you mate
i disabled the plugin and was ok
so now i will install and setup the plugin and try again
im correct in the verbose settings is all i need to enable when i slice my models yes in prusa slicer



ok so i uninstalled octolapse
cleared all settings in doing so
and reinstalled and updated all profiles
set it all up again
but still i get no Z adjust after it takes the pic (pics taking fine now) :slight_smile:

will get the data over to you, not sure how i add the gcode file also
will try


github is not allowing me to attach the 2 files
1 being json file for the backed up settings
and second my sample gcode file

ive uploaded it to my MEGA

hope that works



any news guys, its driving me crazy lol
just cannot get it to z adjust after a shot :frowning:



could these have anything to do with it ?
cant seem to get them to change to green ticks !

Hello everyone, I've been trying for days with both a PICam V2 and a PiCam V1.

Every time I set the frame rate higher than 10, the Firefox 74.0 (64-bit) tab almost freezes. It takes up loads of CPU and RAM until I close Firefox. The Octopi page only shows "webcam stream loading".

The stream itself runs wonderfully via the VLC when I connect to ... / webcam /? Action = stream.

Internet Explorer 11 shows me "Webcam stream not loaded
It might not be configured correctly or require authentication. You can change the URL of the stream under "Settings"> "Webcam & Timelapse"> "Webcam"> "Stream URL". If you don't have a webcam you can also just disable webcam support there. "

The Chrome on the cell phone shows the stream, but jerky.

But since I mostly work with Firefox on the Windows PC, does anyone have any idea how I can get the stream embedded in the Octoprint page with a high frame rate?

Thanks for tips.