Raspberry Pi Camera V2 Settings?

I tested opera portable. This works perfect, even with 40 fps.

I had previously considered embedding the VLC on the octoprint website, but after testing the Opera this is no longer necessary.
In the future I will only use Opera on Windows to access the website. Firefox for Windows does not appear to be suitable for higher frame rates / data rates.

Firefox bombs when i have my camera set to 30fps. It is definitely a bug. Chrome and edge are fine.

I'm sorry, but this is 100% incorrect. The little blue/green sticker with the tab that comes on the lens is ONLY cheap plastic lens protector film for protection during shipping and has zero photographic value. This film should 100% be removed from the lens, as the only thing it can do is interfere with image quality. You can see the same thing also comes on the regular camera..

The blue square that is included is an IR filter and actually blocks some visible and UV light, allowing IR light through to reach the lens. It's use is for IR specific photography (you may have seen the popular white leaves on trees photos as one example), as described a bit here:

Neither the greenish circular protector sticker, nor the square blue IR filter are a proper fix for the pink/purple tint. You do not want to use the blue filter when doing normal daylight photography. The issue is likely due to auto white balance issues in software, which thankfully, it looks like the next version of Octolapse will have settings to correct.

I recently installed v.17 after having v.13 installed for several years and also ran into this issue. The only change I made was swapping microSD cards with different versions of OctoPi.

Well, here we are in times of the lockdown. The cheapest on eBay right now is $125.

Yeah, it is incredible isn't it? My dad got a knockoff of the 920 that he claims is equivalent for way less. I will see if I can get hold of one for testing.

1 Like

I found the same thing. Today I am "upgrading" from C920 to a raspberry camera.
It seems that if you set the resolution values to be a 16:9 set, you get the zoom issue.
If you set it to a 4:3 set, it's fine. Just that simple from what I can tell.

Is the raspi cam a 4:3 camera?
Also, how did you get to the settings pages in the screenshots above, where you can set the camera controls, I have looked everywhere in octoprint, and the webcam settings page is basic, and I can't find that page anywhere else.

Thanks for all the great information!


Hi All,
having the same issue that the one who created this post, I have tinkered a bit and have some beginning of a solution.

reading this : https://www.raspberrypi.org/documentation/raspbian/applications/camera.md it say :

SO .. I give a try to this weird resolution going in /boot/octopi.txt this way :

### Windows users: To edit this file use Notepad++, VSCode, Atom or SublimeText.
### Do not use Notepad or WordPad.

### MacOSX users: If you use Textedit to edit this file make sure to use
### "plain text format" and "disable smart quotes" in "Textedit > Preferences"

### Configure which camera to use
# Available options are:
# - auto: tries first usb webcam, if that's not available tries raspi cam
# - usb: only tries usb webcam
# - raspi: only tries raspi cam
# Defaults to auto

### Additional options to supply to MJPG Streamer for the USB camera
# See https://faq.octoprint.org/mjpg-streamer-config for available options
# Defaults to a resolution of 640x480 px and a framerate of 10 fps
camera_usb_options="-r 1640x1232 -f 10"

### Additional webcam devices known to cause problems with -f
# Apparently there a some devices out there that with the current
# mjpg_streamer release do not support the -f parameter (for specifying
# the capturing framerate) and will just refuse to output an image if it
# is supplied.
# The webcam daemon will detect those devices by their USB Vendor and Product
# ID and remove the -f parameter from the options provided to mjpg_streamer.
# By default, this is done for the following devices:
#   Logitech C170 (046d:082b)
#   GEMBIRD (1908:2310)
#   Genius F100 (0458:708c)
#   Cubeternet GL-UPC822 UVC WebCam (1e4e:0102)
# Using the following option it is possible to add additional devices. If
# your webcam happens to show above symptoms, try determining your cam's
# vendor and product id via lsusb, activating the line below by removing # and
# adding it, e.g. for two broken cameras "aabb:ccdd" and "aabb:eeff"
#   additional_brokenfps_usb_devices=("aabb:ccdd" "aabb:eeff")
# If this fixes your problem, please report it back so we can include the device
# out of the box: https://github.com/guysoft/OctoPi/issues

### Additional options to supply to MJPG Streamer for the RasPi Cam
# See https://faq.octoprint.org/mjpg-streamer-config for available options
# Defaults to 10fps
camera_raspi_options="-x 1640 -y 1232 -fps 10"

### Configuration of camera HTTP output
# Usually you should NOT need to change this at all! Only touch if you
# know what you are doing and what the parameters mean.
# Below settings are used in the mjpg-streamer call like this:
#   -o "output_http.so -w $camera_http_webroot $camera_http_options"
# Current working directory is the mjpg-streamer base directory.

AND going /boot/config.txt this one way :

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#uncomment to overclock the arm. 700 MHz is the default.

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable infrared communication.

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

# Enable DRM VC4 V3D driver on top of the dispmanx display stack

enable raspicam

AND it works !

Quickly, mods are :

# Defaults to auto

### Additional options to supply to MJPG Streamer for the USB camera

camera_usb_options="-r 1640x1232 -f 10"

### Additional options to supply to MJPG Streamer for the RasPi Cam

camera_raspi_options="-x 1640 -y 1232 -fps 10"

### Configuration of camera HTTP output


(according to FormerLurker Octolapse tutorial video)
and in


enable raspicam

Sorry for I'm so bad at BBcode and presenting things.

Hope this will help one's

I'm a bit sorry that it wont work with octolapse as it says :

It's camera full wide with a better resolution but something is wrong somewhere.

I guess I now have to inquire about mjp-streamer parameter and octolapse ones.

Any help welcome.

I think FormerLurker recommends making it this (counter-intuitive)


Yep, absolutely, but, in fact this refuse to work for me at other resolution than "standard" (720P or 1080P).
and has @epiic reason to start this post, I want full camera FOV. assuming they are only in mode 2,3,4 or 5 in raspicam V2 that are verry uncommon resolution.

in my case, I'm studying to pass setting of the camera thru added mjpg-stream raspicam option in octopi.txt, looks promising.

So have done many many many too much tests today.

with raspi, with usb, various fps etc.

my conclusion is : you cannot use raspicam v2 specific resolution under USB driver wich is using


as resolutions here seems to be pre-defined and none correpond to full raspicam FOV mode.

while using USB mode in octolapse you can have access to dynamically modify settings of the cam.
that you cannont in raspi mode.

in fact raspi mode is the only one that can use the full raspicam FOV, even at its max resolution, next come the ffmpeg encoding troubles, but it works at binned resolution.

I'm guessing that "truth is out there" somewhere in the old mjpg-streamer development and in mmal library of raspi.

I say, that raspi uses 3 video pipeline, every one of each should be used in it's own purpose, preview for streaming, still for timelapse and video for recording, but mjpg-stremer won't go so far.

Not understanding why you can't get the full FOV to work. I just did a test at 1640x1232, and it works fine:

isn't the problem really that at full FOV the native raspicam aspect ratio is 1:1.33? if you want full FOV 16:9, you need a camera that does that natively.

So, with "raspi" ful FOV works at 3280x2464 and 1640x1232, but despite I strictly follow your magnificent tutorial on setting as raspicam as "usb", streaming never end loading when using these resolution AND "usb" settings.

Raspi works full res and binned res but can't get parameter (control.htm) relayed by Octolapse neither mjpg-streamer.

then raspi as "usb" works really fine at 1280x720 (>40 fps) or 1920x1080 res and with octolapse parametre working but, with ugly and too narrow cropped FOV (that is due to the rascpicam hardware).

just don't understand why either ... one exclude the other. "usb"=crop + param <=> "raspi"=full.FOV-param !

I'll go on a better camera hardware.