Raspberry pi zero 2 w cannot connecting to ender 3 pro using octopi

What is the problem?

My 2 day old raspberry pi zero 2 running the latest stable octopi cannot connect to my printer

What did you already try to solve it?

  1. Taping the 5v pin
  2. Changing the usb cable 4 times (the cables work with pronterface to my printer and one of them I used 3 months running octoprint on my laptop and thin client
  3. safe mode
  4. Dmesg and pluggin in the cable in my printer again (done this at least 10 times and also with different cables (results are under in the post)
  5. plugging in a usb keyboard a mouse to make sure the otg to usb worked and it worked since the keyboard and mouse worked (led, caps lock led)
  6. asked for help in the discord and read similar forum posts

Have you tried running in safe mode?

Yep, didn't work

Systeminfo Bundle

systeminfo octo.zip (611 Bytes)

Additional information about your setup

Latest octopi on my zero 2 using a working otg to usb and usb cable connected to my ender 3 pro that has worked for months flawlessly with octoprint in the past (first time using octopi)

Dmesg result after reconnecting the usb to my printer:

This systeminfo bundle seems to be broken, it's just a zipped empty file systeminfo.txt

Yes and it keep getting corrupted so I copied the text and made my own zip. I replaced it in the post.

Just linking the background on Discord so it's clear what's already been tried out here.

Thanks Charlie

Finally works!!!!

What I did: I unplugged my printer, the raspberry pi and the usb cable from the printer. Then I started the pi first and after that the printer and then plugged the usb in the printer again when the printer was on and it was able to connect. Not sure why it works this way since I restarted the rpi and printer countless times but I guess I need to do it in this order to make it work. Thanks for the help.

1 Like

Just got my RPi zero 2 w and looking forward to do the same. Is your system now fixed? Plugging/unplugging cables and starting printer and RPi at a different times is not an option for me, as I turn everything on from a smart plug...

What did it for me was the post above I marked as solution. I used a cable that worked for months with octoprint already and taped the 5v pin. (Getting a cable that works is the most important, I had 2 other cables that were newer but didnt work)

If you make it work make sure to do this so you don't have to manually restart klipper after every connect

Edit: oh and btw make sure to backup your sd card once in a while and wait for the pi to be fully off to disconnect the power supply. I just corrupted my sandisk 64g sd card and can throw it away along with my klipper config and all the stuff I configured the past 4 days.

While the corruption makes the filesystem unusable, the underlying SD card can be reformatted and reused, no need to throw it away. I have a USB SD card reader/writer which I use to create SD cards on my desktop and to create clones of the RPi SD card on the RPi.

Tried everything and unfortunately it doesnt work. I tried reformatting in ubuntu, windows and did some more things in ubuntu but couldnt make it work

I've seen similar issues with other users unable to connect to printers when using a RPi zero 2w on the Discord server; one more thing to be aware of:
The zero 2w has 2 USB ports, but you must plug the printer into the correct one. The other port is only for powering the RPi and if you plug the printer into that port it won't be recognized.
If you are unsure, check the RPi board, the ports are labeled.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.