Raspi Camera not working-Very new user

Camera model
Raspberry pi camera v2
What is the problem?
I am extremely new to all things raspberry pi, but was able to get octoprint running fairly well, the problem is that my raspberry pi cam does not seem to work. Initially it will try to load the stream for a while and eventually it will just say that the stream is unavailable. I have tried to follow other posts and the steps they went through, but I do not understand how to do most of the things suggested. Please help.
What did you already try to solve it?
Re-seated the cable going to the raspberry pi, manually chosen the raspi option in the octopi file on my sd card, turned off and back on.
Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

Additional information about your setup (OctoPrint version, OctoPi version, ...)
I am using a raspberry pi 4 4gb rev1.1, octoprint version 1.4.0, using Ethernet not wifi.

my checklist

  • Is the CSI cable inserted the right way? The silvery contacts need to face away from the Ethernet connector!
  • Is the CSI cable fully seated?
  • Did you insert the CSI cable into the Display connector? It needs to be inserted into the CSI connector, which is the one closer to the Ethernet connector.
  • Is the other end of the CSI cable correctly attached to the camera board?
  • Is the camera activated in raspi-config?

do you see a red light on the camera?

The csi cable is inserted in the right way
the csi cable is fully seated
the csi cable is inserted into the csi connector
the csi cable is correctly connected to the camera board

I do not know how to access raspi-config, I am using octoprint and as such have not created a usable desktop interface for the raspberry pi, I do not know how to access raspi-config through the octoprint interface.
Thank you for your ideas so far.

I do not see any light on the camera at all

I just add that in case somebody changed something. You should not need that part with octopi.

Okay, thank you

You will often see in this forum people refer to "connect with SSH to your RPi". This is a valuable skill so I'll attempt to teach it to you. I'm going to assume you have a Windows desktop computer.

  1. Download and install PuTTY.
  2. Open PuTTY and put "octopi" in the Host Name (or IP address) box.
  3. Click the Open button at the bottom of the window. If this fails, you will need to determine the IP address that has been assigned to your printer. Since you didn't tell us anything about your printer, I can only guess. My TAZ 6 displays its IP address on the LCD screen when it is turned on. Use this IP address in the previous step.
  4. Enter the username pi and the password you changed from raspberry (or is it capital R?).

You now have a console or terminal connection to your RPi. While it was determined that it isn't needed, type sudo raspi-config and you should see that the camera is enabled.

If you don't have a Windows desktop or the name octopi isn't found and you can't find the IP address of your RPi. Let us know and provide as much detail as you can about your network. What make/model of router? What kind of desktop? What make/model printer?

1 Like

Thank you, I greatly appreciate this. Your instructions are very clear and easy to follow, which is extremely helpful. I will attempt to do this process later today.

in terminal type lsusb do you see a cam on any usb port?

I'm hoping Ican get some help I purchased raspberry pi 3 model b and followed all the instructions to set up and for some reason it could constantly disconnect from the printer mid print.

I purchased a new raspberri pi same model incase it was a fault with that as I tried different cables and every single forum o could for a solution and that I'd all I was left with.

It seems this no longer has this issue but for some reason the camera stream will not load even though the settings are identical to the previous pi where the camera worked.

The webcam is a microsoft lifecam I've checked and this was a to be know working camera and has done before.

I have been into the terminal I have enable the camera update everything, tried changing stream address but nothing.

The camera initially powers up but then the light goes off after a few seconds I have type lsusb and seen that the camera isnt connected but I have no idea why

You can use PuTTy to SSH into your rPi once it is connected to your WiFi.

Once logged in via SSH you will get a command prompt.
sudo raspi-config

Go to 5 Interfacing Options using the arrow keys
Select P1 Camera and hit yes to turn it on and hit OK
Arrow down and over to select Finish and then reboot

Couple of other notes on the rPiCam. There are only a few supported resolutions, you must use a resolution that is Fully supported (not Partial FOV).
See here for info on the issue, supported resolutions and what to do.

In order to change the settings in the /boot/octopi.txt file as mentioned in the link above, SSH in and at command prompt, type sudo nano /boot/octopi.txt Use arrow keys to get down to the lines you want to edit. Make sure you uncomment out the line by deleting the # in front.

Also focus is done by manually turning the lens. You can print a tool to safely turn it. Be careful because the lens can pop out if you turn it too much and it is not easy to get back in (also dirt can get in if you are not careful).


I just had the same issue with a new camera. I had to switch from the CSI to the DSI which is the ribbon connector next to the HDMI Connector NOT the ethernet port. After making that switch all worked perfectly. This link was very helpful.