Raspi Pi Camera Not Working

Hello,
I´m setting up octoprint on a printer (Ender 3 Pro) for the first time.
Everything works perfect, except for the camera. It doesn´t show up on stream. I don´t know if the camera has an LED, but it doesn´t light up as well.

One of my biggest problems is, that I don´t underrstand most of the tips from other threads.
I´ve read stuff about sudo raspi-config. I don´t know where to type this command and stuff like that.
So please be patient with me.

Raspberry Pi 3 Model B ARM-Cortex-A53
LABISTS B01 Raspberry Pi Camera

I hope that´s all the info you need.

Hi,

I hope this might clarify what someone might mean when they ask you to send a command to the Pi.

Your Octoprint Server is still running an operating system, Rasbian if I am not mistaken which out of the box, has the camera port on the Pi disabled. You need to access the Pi via a terminal to enable this but that is not possible by normal means because we usually communicate with our Pi's in what is called "Headless mode" or in layman's terms, not having a Monitor, KB and Mouse connected.

So here is the magic, you need to access the Pi's terminal like I said before but through your network. This is done with SSH software like Putty in Windows. This will allow you to simulate a terminal window but you will be doing so over Ethernet Vs. conventional physical means.

To answer your question on raspi-config, you first need to download Putty and know what IP address your Pi is (Same as you type to get to octopi interface). When you enter your IP into putty and connect for the first time it will ask you to accept the security cert., press yes. It will then ask you for your username (for the Pi) it is default as "pi" without the "" of course. Next it will ask for a password which is "raspberry" by default, again no "". It might ask you to change that if you would like, I would highly recommend to do so but remember it as you will need it again soon (The password can be changed in raspi-config as well). Now you should be presented with a the opportunity to type "sudo raspi-config" and hit enter (sudo password will be asked and is the same as before). The screen will change to an old looking blue background with grey dialog box. Look for "interfacing options", use the arrow keys and enter key to get to it. You will see the next screen show camera interface, hit enter and yes to enable it. Now exit the raspi-config and reboot the Pi, you should see the camera if the ribbon cable has been connected correctly of course.

Raspi-cam has no LED's so unfortunately trial and error will be your friend for the day.

Please Youtube Putty and raspi-config for more info if you need it.

Good luck!

1 Like

Thank you very much for your help up to this point. After an hour of struggle I managed to get into the rasp-config. I enabled the camera setting and rebooted the pi. But it still doesn´t work.

Is there any Stream URL I need to fill in?
I use the default /webcam/?action=stream.

The default URL will work for the Pi camera straight away.

Lets try this, get back into putty and instead of raspi-config, try some of these camera related commands:
https://www.raspberrypi.org/documentation/raspbian/applications/camera.md

They should return, at the very least, still images from the camera. If you get errors or no photos then you still have issues on the raspberry side to figure out. Remember to use sudo with these commands as most of them will need admin rights to perform correctly.

Take this one step at a time, also before the above, try "sudo apt update" then "sudo apt upgrade" and "y" to any prompts of course. This will make sure the software is up to date just to make sure that is not an issue as well.

Good luck!

Thank you soo much!
sudo apt update and sudo apt full upgrade finally did the trick.
I would´ve been totally lost without your help.

1 Like

Thank you for this post. It helped me too.

This was extremely helpful. Thank you!!! Enabling the camera and the sudo update did the trick!

Thanks for the explanation! Helped me to setup my RaspiCam with a Pi 4b :metal: