Was working fine, now I cannot even access the Pi

What is the problem?

Ok, I followed this youtube video on how to setup the octopi. Went easy and I was up and working pretty quick. I ran a few prints from the octoprint raspberry pi4. I then decided to add the camera to the pi. I turned off the raspberry pi and installed the camera.

I then opened up octoprint on my PC (the only way I have to access it) and while I could connect, there was no video feed coming in. I looked and found this post that seemed to maybe address my issue. So I followed it.

I downloaded putty and was able to follow the post to complete the "sudo raspi-config" I then went and enabled the camera.

I have not been able to access octoprint or the raspberry pi since.

What did you already try to solve it?

I tried a few things I read, nothing worked, I eventually formatted the SD card and ran back through the entire setup process, and still the same.

If I try to open http://octopi.local I get a server not found error. I tried to go back into putty, I had to use the ip address(not sure if that's how I did it the first time) but the name http://octopi.local just gave an error.

When I put in the ip address I could enter the user:pi but the password was not working. I did not change the password from raspberry.

I am new to raspberry pi's and 3d printing in general, so I might just be missing something easy and obvious to everyone else.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Don't know how??

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

EDIT Ok redid it all again and figured I should get this information while I had access.

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 8204619776
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3 V2. bugfix-2.0.x firefox windows 10

Hello @ch5richards !

Do you have the chance to connect an HDMI TV/monitor to the Pi?
There should be a startup sequence anding with some information that includes the actual IP address of the Pi.

As of now, no, I have no way to hook it up. I have ordered a micro hdmi cable to help, but it will not be here till tomorrow.

Ok, a bit of an update. I am still waiting in the hdmi cable, but I did dig out my 100' ethernet cable just to see if I could connect that way. Not sure what I did or what it did but it is working now.

Now I will try to hook up the camera and if all is well try and get back to wireless.

Well, all was good until I plugged up the camera. I again followed that guide to enable the camera. Exited putty. Turned off the PI, plugged in the camera and I could not connect after that. The PI does not show up on my network either now...

I tried unplugging the camera but i still cannot connect.

What did I do in putty that won't allow it to connect?


Ok, re did everything again. Added the system info bundle above now that I could get it,

Found out it is not putty. Made all the changes in there and restarted the PI without hooking up the camera. Everything worked. I turned off again plugged in the camera and it will not connect to network again.

Wrote that a few hours ago, thought I posted but guess I just left it...

I got it up and running. Not sure what I was doing wrong? Maybe not waiting enough during some of the restarts? I don't know, but now I can go back to trying to fix my print issues.

Thanks for the assistance, hopefully I won't need anymore

What did you do in Putty?