Restoring Old Plugins and Files

What is the problem?

I have been running Octoprint 1.3.12 and Octopi 0.16.0 for more than a year now with no problems. All of a sudden the Octoprint server wouldn't start and I kept getting the "Octoprint server is currently not running" message. My Raspberry pi was connecting to my network and I was able to access it via SSH through Putty. After trying numerous fixes, I downloaded another copy of Octopi (this time 0.17.0) and flashed it to a new SD Card. When I inserted this into my Pi, the server was again working and I'm able to print over wifi. The "problem" is that all of the plugins I had previously installed and all of the files that had been previously uploaded are no longer there. Is there some way to retrieve them from the old SD card and transfer them to the new card or have these been lost forever?

What did you already try to solve it?

When the old SD card was in place, I tried all of the fixes that are suggested in the Octoprint server is currently not running" message. That is, 1) I tried to verify that the process is running and it was not, 2) I tried to restart the server with the sudo service octoprint restart and nothing happened, and 3) I looked at the logs but there was nothing in there that was helpful to me anyway.

Have you tried running in safe mode and if so did it solve the issue?

NO

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

I don't have access to the logs since I'm running from the new SD card. I can insert the old card and get the log files, but primarily I'm interested in retrieving the old plugins (since I'm not sure exactly which ones I had installed) and the old uploaded files

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.3.12, Octopi 0.17.0 now, previously 0.16.0, CR10 mini running Marlin 2.0, Windows 10

The FAQ is your friend:

Gina,
I'll give a try tomorrow. Hopefully I'll be able to copy the files from the SD card containing the server version that isn't starting to the one that is. Thanks for your help.