Resume does not check tool & bed temperatures

What is the problem?

When I pause my print with the Octoprint pause button for an extended time on my Prussa MK3S the printer shuts down the heaters on its own. When I select the resume button in Octoprint it does not heat up the tool nor the bed, it just runs off and tries to lay down more plastic.

What did you already try to solve it?

read through this forum, did not find anything relevant.

Have you tried running in safe mode?

yes

Did running in safe mode solve the problem?

no

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
browser.user_agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:94.0) Gecko/20100101 Firefox/94.0

connectivity.connection_check : 1.1.1.1:53

connectivity.connection_ok : True

connectivity.enabled : True

connectivity.online : True

connectivity.resolution_check : octoprint.org

connectivity.resolution_ok : True

env.hardware.cores : 4

env.hardware.freq : 1500.0

env.hardware.ram : 3959304192

env.os.bits : 32

env.os.id : linux

env.os.platform : linux

env.plugins.pi_support.model : Raspberry Pi 4 Model B Rev 1.2

env.plugins.pi_support.octopi_version : 0.18.0

env.plugins.pi_support.throttle_state : 0x0

env.python.pip : 20.3.3

env.python.version : 3.7.3

env.python.virtualenv : True

octoprint.safe_mode : False

octoprint.version : 1.7.2

systeminfo.generator : zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Everything is very vanilla and up to date.

Hello @gjpc !

Have you seen this?

And please do:

I copied the system info into the post where it said system info. I have no idea where the button on your posted graphic is in the forum, I never saw it. If it helps I uploaded the zip file to this post. octoprint-systeminfo-20211122123638.zip (29.5 KB)

It says systeminfo bundle:

grafik

It's not in the forum, it's in your OctoPrint installation.

And you stumble upon it before you click More to get the systeminfo:

To your issue:

If the printer turns heating of after an extended time and does not inform OctoPrint about it, OctoPrint does not know that that happened.

In the OctoPrint log there is no appearance of a pausing or a resume.
It is too short.

Thank you for your help @Ewald_Ikemann ! I am running in safe mode now awaiting the printer to time out the heaters. When that happens I'll post again with a new system info zip file and observation if the temperatures are reported in Octoprint.

1 Like

This is a bit of a problem with Prusa's firmware, and they consider it a feature rather than a bug I think...

If I remember right, the solution from them was 'use the resume button on the printer'. I'll try and dig up the thread on their firmware repo.

Here you go, if you fancy a read:

Oh - it looks like there's another work around adding M601/M602 to OctoPrint's gcode scripts there. Forgot about that one.

1 Like

Thanks @Ewald_Ikemann @Charlie_Powell Just for completeness I ran in safe mode and got the same results. Info file attached. The behavior I see between MK and Octo:

  1. Press Octo Pause
  2. Wait (long time)
  3. MK times out and turns off heaters and waits for a control knob press during which the Octo console states paused by user
  4. Press continue in Octo and nothing happens
  5. Press the MK control knob and temperatures start reporting but Octo just plows on printing with Octo reporting temperatures on the floor. Fortunately the MK replies I ain't pushing no plastic when I'm cold. (at least that's what I got out of Když je mi zima, netlačím žádný plast)
  6. I then canceled the print.

I think this behavior can easily be recognized and corrected in Octo software. I read the [BUG]3.10 (M601) report on github, and frankly I can't make nose from ass on that thread. (I'm autistic and never could get along in a room with more than 2 people speaking). Anyway it looks like the bug is not marked solved. I have been programing computers since 1966 and professionally programing since 1974 at Bell Labs, NASA, Intel, etc so I can probably solve this in code. However I am reluctant to engage this early in a community that I know nothing about.

Any advice?

octoprint-systeminfo-20211122145407.zip (37.7 KB)

This is part of one of the comments 'claiming' to be the solution:

To use FW3.10.0 correctly with an USB host system like Octoprint you need to add in GCODE scripts
M601 in After print job is paused
M602 in Before print job is resumed

Interesting @Charlie_Powell, Prusa Forum sheds more light. Maybe this can be solved by adding a Prusa specific pause and resume script that Octo will run with the triggered feature. Currently digesting this

OK, I have the solution to this problem that only works on Prusa firmware 3.01 or later. If you do have a Prusa MK with updated firmware perform the following steps in your Octoprint.

  1. select the Spanner (wrench) at the top of the OctoPrint page
  2. select GCODE Scripts in the left hand column
  3. enter M601 ; pause the print in the After print job is paused text box
  4. enter M602 ; resume the print in the Before print job is resumed text box
  5. enter G4 P5000 ; Dwell in the Before print job is resumed as the second line in the text box
  6. select the Save button at the bottom of OctoPrint Settings

You will find two new scripts in your scripts/gcode directory afterPrintPaused and beforePrintResumed

When you select the OctoPrint Pause button the print will pause, the hot end heater will be turned off and the the print head will politely move away from the print. The bed heater will stay on to keep the print adhered to the build surface.

Selecting Resume will pickup the print exactly where it left off.