Says stream url is empty, but its not + webcam issues

EDIT: fixed

I'm getting this in the Control tab with my Xbox 360 camera:

Webcam stream not loaded
It might not be 
correctly configured. You can change the URL of the stream under "Settings" > "Webcam & Timelapse" > "Stream URL". If you don't have a webcam just set the URL to an empty value.

It was working 5 minutes ago, then froze. I'm on the latest Octopi. Here is my /var/log/webcamd.log:

logger: Starting USB webcam
Running ./mjpg_streamer -o -w ./www-octopi -n -i -r 640x480 -f 30
MJPG Streamer Version.: 2.0
 i: Using V4L2 device.: /dev/video0
 i: Desired Resolution: 640 x 480
 i: Frames Per Second.: 30
 i: Format............: JPEG
 i: TV-Norm...........: DEFAULT
Unable to set format: 1196444237 res: 640x480
 Init v4L2 failed !! exit fatal 
 i: init_VideoIn failed

My octopi.txt is all commented out (that's what it was by default). The stream url in settings is /webcam/?action=stream, which shows The webcam server is currently not running. In addition, the camera is shown is lsusb.

Fixed it with help from - please delete this thread.

I could imagine this is something that others might run into, so I'd definitely not delete it. I've seen some posts here that get marked as solved with a link to the post that solved it, but I can't see how that's done.

Had to be fine by either the topic author or a mod. I've done it with some topics over the past couple days which definitely were solved but where the OP didn't seem to be interested into marking the solution.

@hkyq would be great if you could move your own "it's fixed" post as the solution - doesn't hurt, helps others :slight_smile:

Thought that might have been the case, so I looked at my own post in General to see if I could figure it out, but maybe that doesn't apply to topics in that category.

It's a category specific thing. "Mark as solved" is currently only enabled for "Get Help" and I think I also enabled it in "Plugins". Not sure if it would make sense in one of the others :thinking:

Yep, agreed. Thread hijack: complete.

1 Like

Sorry, was away. How do I mark as solved?

edit: nevermind, I just added solved in the title

Marked it properly as solved. Just for the record:

1 Like

The wiki has moved and therefore the link from the solution is no longer correct. Could someone put the updated link here again?