Server stops when computer locked

Followed this guide to setup Octoprint for windows: Setting up OctoPrint on Windows - Get Help / Guides - OctoPrint Community Forum
Everything works fine, except when use remote desktop with the pc running octoprint.

What is the problem?

When I disconnect the remote connection, the octoprint server will stop until I log in again.
this means that if I remote in mid print, I cannot disconnect, otherwise printer will stop printing
or I can't remote in when it's printing

This is a problem since I'm also using the pc to do other things, and I need to remote in from time to time.
And I can't switch to a pi, as I don't have one, and availability isn't there in my region/still way too expensive

What did you already try to solve it?

I've disabled all the sleep and updates on the pc, but I think the problem is related to the account locking up when remote connect disconnects, not sure what I can do there.

Did running in safe mode solve the problem?

Safe mode made no difference

Systeminfo Bundle

octoprint-systeminfo-20221019143403.zip (52.0 KB)

Additional information about your setup

Windows 11 22H2
Ender 3 v2
Octoprint Version 1.8.6

Quick google solved the issue:

instead of disconnecting normally, run a command in cmd
tscon 1 /dest:console

This returns control to the host pc, so it doesn't lock up.
but host PC will be UNLOCKED afterwards, which may create security concerns in some situations.

an alternative would be to save the file on the sd and print from sd I guess, but transfer rate to the sd card is so slow..... and a lot of features wouldn't work with print from sd

Hi there :slight_smile:

In case nobody can help you here, you should try it in a Windows related forum. Most users here are using either linux or don't use a remote connection on their OctoPrint host PC.

There is also the option to install linux on your PC :wink:

1 Like

I'm not sure I understand the configuration completely. You have a Windows 11 system with OctoPrint installed and connected to your Creality Ender 3 V2 via USB. Let's call this system O. You have another Windows system and let's call this system R.

Which system are you connecting to using Remote Desktop?

I believe this issue could be solved if you can get OctoPrint running as a service. I took a brief look at the guide you linked in your initial post, and I don't see any instructions on how to do that. Perhaps this project would help.

1 Like

I'm using System R to connect to System O, O is the host, R is the remote.

Setting octoprint up as a service is an interesting idea, i'll look into it thanks.

@jneilliii has an up to date (& working as far as I know) windows installer that sets up the service here:

2 Likes