πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Setting up OctoPrint on Windows

Yeah, just tested my dev box and don't see any issues with yawcam and stream. Assuming you have yawcam like this...

image

The only other thing I could think of is windows firewall settings blocking the connection.

I'm setting up a windows based system. What do you use to monitor remotely. Ideally with an iphone.

I used anaconda (conda) as virtual environment and it works fine too.
You need to

  1. Install the Microsoft Visual C++ Compiler for Python 2.7 (see above)
  2. create environment with python=2.7

conda create --name octo_py27 python=2.7
activate octo_py27

  1. Install octoprint in that environment

pip install https://get.octoprint.org/latest

  1. Run it

`octoprint serve

  1. You can also create and run octostart.bat:

call <path_to_conda>\Anaconda3\Scripts\activate.bat <path_to_conda>\Anaconda3\envs\octo_py27
octoprint serve
pause

I use yawcam, and I have mine setup virtually that way except I had something else using port 8081 so I changed it and my stream link looks like this: http://192.168.0.111:2500/video.mjpg

I submitted and got a Raspberry Pi. But I'll try this, too. Thanks!

1 Like

Hi,
I have completed the installation procedure but got stuck on the last bit. When I execute octoprint serve my cmd keeps telling my 'We are not online'. I'm running my cmd as an administrator but still I get the same error.

Continuing the discussion from Setting up OctoPrint on Windows:

hi!

i have already tried to install Octoprint on Windows with the newest release of python 3.7.1rc1, but it didnt work.
i wanted to ask, if it in general possible? (maybe i have made some mistakes)

p.s Octoprint with python 2.7 works perfect!

thank u!

Hi Malinka!

So it should be.

first and For most AWESOME WORK! Octoprint is AMAZING!

I have been running it on a old windows laptop for a few months now, i cant believe how blazing fast it is compared on a my pi version.

So i am trying to setup a 2nd octoprint session on the same windows box. so i can run two or more printers at the same time, (theoretically this should be possible) as we can do it on a pi.

I created a new folder c:/octoprint2 and installed a second version of it.

The only issue i am running into is how would i go about changing the port number from 5000 to 5001

the only file that i see is netaddr but i am not seeing anything in it what would indicate a port address to modify.

any ideas would be helpful.

Niels

Danielkrah,

Thank you, for the info, but the key issue is i am running this via Windows running on python v2.

so doing it this way their is no ssh access to the session.
and the python folder dose not contain a config file for the octo print session, i assume its hiding somewhere and is accessible somehow.

the only thing i can find is the config.py

this dose not contain the octoprint config settings.

so

C:\OctoPrint\venv\Scripts\octoprint.exe serve --port=xxxx

doesn't work ?

That works sorta
C:\Octoprint2\venv\Scripts> .\octoprint.exe serve --port=5002

i can now access the session via port 5002, however it is the same session as port 5000 it dose not different session at all.

hmm.

what i did was re-install everything in a folder called octoprint 2.

any ideas?

It's probably worthwhile searching this forum (the magnifying glass in the upper-right corner) for "multiple". This topic has been discussed many times and you're missing the benefit of reading some of that commentary.

I got this message and that is strange:

OctoPrint>pip install //get.octoprint.org/latest
Downloading //get.octoprint.org/latest (5.3MB)
100% |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 5.4MB 788kB/s
OctoPrint requires Python '>=2.7.3,<3' but the running Python is 3.7.1

MUST I install the older version??
-; >= does mean Greater or Equal

You are fine with 2.7.15
And yes, you can have installed both versions parallel.

Is there a way to add access control on a Windows setup like on this page? I can find a plugin or how to turn on access control like the pi version does.

@ Foosel

i want to do a Big shout out to Chris Riley, who just posted a video walk threw on setting this up with multiple instances.

Could you please make him a Sticky!

1 Like

I had the same issue but it was just because http;// was missing before the IP address.

Is the 0.16.0 Update available for Windows as well?
Just tried to update with your recommended update instructions:

  1. Stopped Octoprint
  2. C:\OctoPrint>venv\Scripts\activate.bat
  3. pip install --upgrade https://get.octoprint.org/latest")
    It doesn't seem like it has installed the latest version. After starting Octoprint server again it shows version 1.3.10

I get the message "Cache entry deserialization failed, entry ignored" after calling "pip install..."