🇺🇦 We stand with Ukraine! 🇺🇦

Setting up OctoPrint on Windows

1 Like

In preparation of the upcoming py3 compatibility I'm working on setting up my dev environment and was wondering if these steps are going to be roughly the same? Is there a reason for using 32bit over 64bit version of python?

Setting up a Development environment in the devel version of the docs has been adjusted for "dual wielding", you might want to check that. Windows specifics are still missing though.

When I wrote these steps there were a ton of issues with the availability of 64bit eggs (there were no wheels back then IIRC) and compilation under Windows with 64bit was also an absolute nightmare. The combination of those things made it an absolute pain to get up and running, whereas 32bit just worked(TM). Things might have changed now. I'm honestly not sure if my Py3 install is 32 or 64bit :thinking:

I managed to get Yawcam to work with streaming. Now I want to add a username and password to it.
Once I added that in the Yawcam Settings, I can't seem to view the stream even after embedding the credentials in the URL like this:


It keeps popping up a login window in Chrome and when used in OctoPrint settings, it fails to render the image when I click the 'Test' button.

Is there any way to do this?

installed on Windows 10, drivers for COM installed. When I try to connect in Octoprint, I get this error:

Connecting to: COM4Changing monitoring state from "Offline" to "Error: Connection error, see Terminal tab"Unexpected error while connecting to serial port: COM4 SerialException: 'could not open port 'COM4': WindowsError(5, 'Access is denied.')' @ comm.py:_openSerial:2478 (hook default)Connecting to: COM4Changing monitoring state from "Offline" to "Error: Connection error, see Terminal tab"Unexpected error while connecting to serial port: COM4 SerialException: 'could not open port 'COM4': WindowsError(5, 'Access is denied.')' @ comm.py:_openSerial:2478 (hook default)

Im trying to insall octoprint on windows 10. Im using python 2.7.15 and when I try to install the octoprint via this line:
pip install http://get.octoprint.org/latest
I`m getting an error: Error 42:
"1% |could not install package due to an EnvironmentError: [Error 42] Illigal byte sequence"

how can I solve this error and install octoprint on my PC??


If I install it on my PC, I can use my built in webcam correct?
Also, as a preventative "computer can reboot" kinda thing, can I still print from my SD card directly to the printer and just use octoprint to monitor it?

I could use some help I already tried googling it and couldn't find anything.... my octoprint runs on my windows PC and I am using yawcam to control my webcams that can both out put in 1080. I would love to render octolapse videos in higher resolution but as far as I can tell you have to edit the octopi.txt file which the windows version of octoprint doesnt seem to have. Anyone have any ideas?

OctoPi camera initialization is normally done through octopi.txt. Windows camera initialization is different.

OctoPrint uses the camera in both OctoPi and Windows through the stream and snapshot URLs. The camera resolution and other parameters were handled at initialization.

I have install successfully python in 32 bit and running well. I made sure to include pip in the installation.

hi. i'm new in this matter , any idea what to do or what i do it wrong when installing from here : checking the API key... but never finishing.

. i change it the address from 80 to 3344 but not working. the octoprint said is connected with printer but i can't connect with cura 4.3 version. thanks.

OctoPrint normally doesn't run on port 3344. It runs on port 5000 and with the help of haproxy, it also is seen on port 80, the default.

Also, keep this to one thread please. You've already asked this somewhere else on here.

i try it with 80 too and not working. of course i asked ,where i saw that is about this problem.what else to do? and how to try with port 5000 and haproxy? a step by step guide ? something somewhere is missing and can't be connected together.

Setting up OctoPrint on Windows

You're on the step-by-step guide here. Start from the first post.

1 Like

fieldOfView helped me. thanks.

@frakman1 How did you get your Yawcam to work, I have spent way to long trying.

This might help

Did my download and install on win10, python 3.7, running it in admin powershell.
I go to localhost:5000 and it just spins and say "Loading Octoprint's UI, please wait..."

you need python 2 - unless you want to test the latest dev rc

Only 27 days until Python 2 goes to Sunset mode.
Python 3 has been out for 11 years.
I'm a software developer and having Python 2 on my machines causes a lot of complication in terms of path and environment management for my commercial work.