Setup on mac does not finish


#1

What is the problem?

Octoprint setup doesn't finish after the last command octoprint serve, No errors in the setup before followed these instructions: https://github.com/foosel/OctoPrint/wiki/Setup-on-Mac

Here some of the terminal feedback:

2019-03-02 20:47:42,440 - octoprint.util.pip - INFO - pip installs to /Users/VM/OctoPrint/venv/lib/python2.7/site-packages/ (writable -> yes), --user flag needed -> no, virtual env -> yes
2019-03-02 20:47:42,441 - octoprint.util.pip - INFO - ==> pip ok -> yes
2019-03-02 20:47:42,448 - octoprint.plugins.softwareupdate - INFO - Saved version cache to disk

nothing after that, and cant type in the terminal, octoprint also is not reachable in the browser.

What did you already try to solve it?

I tried to install multiple times

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Mac book Pro late 2011 10.13.6


#2

Did you try http://localhost:5000/ ?

How about ps -ax|grep octoprint ?


#3

Returns this:
3945 ttys001 0:00.00 grep octoprint

localhost is not available


#4

I've just adjusted the documentation in question noting that access URL, for what it's worth.

These instructions include a line pip install -U pyobjc. I'm not convinced that this is necessary.

This is me doing this on my MacBook:

cd ~/sites/OctoPrint
source venv/bin/activate
octoprint serve

2019-03-02 12:15:31,613 - octoprint.startup - INFO - ******************************************************************************
2019-03-02 12:15:31,614 - octoprint.startup - INFO - Starting OctoPrint 1.3.10.post5+g8ce2290d
2019-03-02 12:15:31,616 - octoprint.startup - INFO - ******************************************************************************
# etc

I open a second Terminal with Cmd-N:

ps -ax|grep octoprint
10429 ttys001    0:03.22 /Users/me/sites/OctoPrint/venv/bin/python /Users/me/sites/OctoPrint/venv/bin/octoprint serve
10463 ttys002    0:00.01 grep octoprint

From that second Terminal I open a Safari window to the site:

open http://localhost:5000/
# I observe that this brings up the web interface

Okay, so all that assumes that the service started and that I followed the instructions.

I note that you didn't say "oh, btw, I decided to spin up a virtual machine on my MacBook with Linux on it" or something like that. And yet, I see from the path /Users/VM/OctoPrint/... that this could be what you've done unless your name is Victor Morris, for example.

Assuming that you're not running in some sort of VMware environment...

Having run the source venv/bin/activate command and being in your OctoPrint directory, try the following command: pip install -e . (noting that there is a period at the end of that). Once you've done that, try the octoprint serve again and see if it now works.


#5

Thx for the help, worked now! The name VM is the username i set all of this up, I plan to set up some vm's beside octoprint on that machine, all native OSX :wink:


#6

What are the commands on OSX to call a restart of octoprint?


#7

How do I reach the octoprint server from an other device in the network tho? ip adress like on my pi does not work.


#8

Restart: run sudo service octoprint restart

Your Mac uses Bonjour behind-the-scenes so it ought to then advertise itself on your local network using its hostname.

What is my Mac's hostname: run hostname

Once you have that, it's then http://hostname:5000/


#9

Works so far only Problem I got is octoprint does not recognize the printer. Only if I restart the mac, it works until I turn of the printer, after that the printer shows up in the usb section of the mac info, but Orctoptint does not see the serial. Installalled the newest drivers too. It a CR 10S Pro and shows up as FT232R USB UART.


#10

macOS should have issued the serial connection a device. Usually on my Mac within the OctoPrint -> Connection side panel widget the pull-down will indicate something new when I plug in a MEGA board via serial.

You might have to run sudo dmesg to figure out the device. Or you might have to run ls -l /dev both before/after plugging it in, noting the difference. Since macOS will issued odd-looking device names compared to Linux, you might need to go into Settings -> Serial and add something to where it searches.

What's my port?

# Make sure it's unplugged
ls -lha /dev/tty* > ~/before.txt
# Now plug it in
ls -lha /dev/tty* > ~/after.txt
vimdiff before.txt after.txt

Printer does not show up on OSX
#11

Finaly got to test your suggestion:


Don't really know what to take from it ^^ Would be very gratefull for further help on it.
Where do find serial settings in OSX?


#12

Maybe that's then either /dev/ttys000 or /dev/ttys001. Go into your OctoPrint -> Settings -> Serial and add those two ports and see if it can Connect using AUTO.