[SOLVED] Did Octoprint just crashed my SD?

Hi everyone!

I have successfully been using OctoPi for approximately 1 year. But today I faced a major issue...
My printer suddently stopped printing.... The hotend was hot, the bed also, but the carrier was no more moving. I tried to connect through the web interface (on my local network) and faced a Time Out error... I tried ssh... Same error...
So I had no ther choice than taking the power off the PI... And when I plugged the power back in, the PI was no more able to boot. After few checks, the SD Card is dead (à 32 Gb SanDisk SDHC Class 10...)

After discussing with some friends, this kind of issue is quite know on the PI, because of Raspibian (reading and writting many many files...).

So I got 2 question for you:

  • Do you think this crash might be linked to the Octopi behavior (or am I just unlucky :slight_smile: )?
  • Do you think we can transfer folders in RAM for the Octopi?

regarding the second question, and to give you more details, I found out a "proposal" of solution, using tmpfs (so using the RAM instead of the SD for some folders). The idea would be to change the tmpfs this way:

tmpfs /tmp tmpfs defaults,noatime,nosuid,size=10m 0 0
tmpfs /var/tmp tmpfs defaults,noatime,nosuid,size=10m 0 0
tmpfs /var/log tmpfs defaults,noatime,nosuid,mode=0755,size=10m 0 0

It might already be the case, but as my SD has crashed (and I do not have another in backup), I am waiting for the RMA of SanDisk to provide a new one....

Thanks for your feedbacks on that, and have a great day

Sadly you immediatly removed the template that was supposed to guide you make a proper Get Help Post.

Besides you have trouble, we know nothing.

What Pi, what version of OctoPi and OctoPrint, what printer and most important: the logs!

That's not really sadly, but I am quite interested on how you manage to grep logs on a broken and no more recognized SD Card....

Regarding the OctoPi version, I moved to the latest release 1.4.2 few weeks ago (I remember it because i moved to the 1.4.1 and just few days after having issues with the plugin layer, it was announced to be fixed on 1.4.2).

This help request is more linked to the global behavior of OctoPi: Could it crash SD cards as Raspbian does (did anybody faced this kind of crash after one year), and is the use of tmpfs compatible with the noominal Octopi behavior.

To be complete, my printer is printed almost h24 d7... for almost one year

Hey @LordDarkneo!
OctoPi can, does and will not hesitate to corrupt your install if you just pull the power from the Pi (among other causes). It is Raspbian, with OctoPrint preinstalled. Pretty much anything you can do with Raspbian can be done on OctoPi, since it is just an optimized image.

You have got confused with this bit:

That's the OctoPrint version, not OctoPi version. Current release of OctoPi is 0.17. More:

This isn’t really a Pi issue per sa, this applies to anything, but the sort of device flash cards were designed for, cameras and phones, this would never have been an issue. This is why computer SSD drives have lots of extra electronics (and much more expensive) in them to handle these sorts of issues.

It is hard to tell how long an SD Card will last. There are lots of cheap and knock of cards on the market, but even expensive ones can fail quite quickly. Others seem to go on forever.

I have run a firewall off a flash card for a decade, and a Pi4 Plex server for 18 months, and have original pis with original sd cards. It is quite hard knowing when they will fail.

But things like not shutting down properly, under voltage, lots of writes, excess heat etc, don’t help if the card is exposed to that sort of thing. And indeed any thing that might corrupt a traditional unix file system on a spinning disk pretty much applies to an sd card as well.

Hello all and sorry for late answer.

My bad, yes I swapped the OctoPi and OctoPrint version... The Octopi was 0.17.0, and the OctoPrint has been upgraded to the 1.4.2.

Regarding the SD card (mainly the reason of the delay), I was able to get a brand new one through the RMA process (10 years warranty) and I just get the new one.... And the RPI is not booting with this new card :cry:

I tried the OctoPi: Red led is on, no blinking green, nothing displayed...
So I tried to move to a brand new Raspbian: same behavior...

So I guess my RPI 3B+ has just crashed (for an unknown reason) killing the SD card (and probably other components).

I have just ordered a new RPI 3B+ mobo, I'll give a try in the coming days.... Just to let you know, my 3B+ was 2 years old....

Regarding the tmpfs usage, did anybody tried this on OctoPi/OctoPrint? Can it be done or is it safer to use a complete RO Octoprint (detailled here: https://gist.github.com/basilfx/a099d4f64407c42e716d)?

Just to keep you posted, the new motherboard is working fine.

Any feedback on the tmpfs usage or full RO for Octoprint?

Edit: Just to let people know: I did not (yet...) switched to tmpfs (logs are quite useful...) but I think that was more an hardware issue with ma RPI board (that kinda crashed the SD Slot, and the SD within it...)