[SOLVED] Ender5+ nozzle & bed temp no longer heating from Octoprint

If you're on FW 1.70.1BL & 1.70.2BL --> Remove the SD card and it works fine..

What is the problem?

I recently had to rebuild my Octoprint server (Raspi4) and now it won't heat both the nozzle and bed. It will heat whichever one is first in the gcode, but the second request to heat the other one is ignored, and I get the scary "Your printer didn't respond to heating, something may be wrong" screen on my printer LCD.

Printing the same gcode directly off the SD card (without using octoprint) works perfectly, so I think I've ruled out any physical/electrical issues.

Note: Prior to rebuild of Octopi, I was using Octoprint successfully with the exact same equipment. Heating worked perfectly, and this issue only showed up now after the octoprint rebuild.

What did you already try to solve it?

  • I've edited the gcode directly to swap M109 and M190 commands to see if the issue was specific to one or the other heater, but it turns out which ever one is listed first gets to temp just fine, the second one times out.
  • Printing direct from SD card using same gcode heaters work perfectly and print as expected.
  • I've tried (only a little bit) issuing the M109/M190 commands in the Octoprint terminal, but that didn't seem to do anything (not sure if I did it correctly so may not be a valid test)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 3971153920
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
systeminfo.generator: systemapi

Additional information about your setup

I've got a data-only cable connected to my Raspi, so don't think it should be any sort of back-powering issue.

See Attached Terminal Log
Ender5plus_terminal_debug.zip (1.8 KB)

Your firmware reports the temperature in a weird way.
This plugin should fix it

I think that plugin is strictly for display (Recv) in the Terminal. My issue seems to be more about Send command communication to the printer.

For good measure, I did just install that plugin you suggested, but got the same result after a quick test print via Octoprint.

Do you have an SD card in or out when you are printing from OctoPrint? Seems like a random question, then scroll up on this thread:

Yep, the firmware version matches the ones in the thread above & in this FAQ article:

1 Like

:man_facepalming: Well, that fixed it. Popped out the SD card and now it works just fine. What a silly but extremely annoying bug!

I guess that's just more incentive for me to get the BigTreeTech SKR Pro 1.2 I ordered installed and flashed with Marlin FW. It's too bad Creality doesn't have a better QA process on their firmware.

Thanks @Charlie_Powell

1 Like