[SOLVED] OctoPrint not running after power loss

What is the problem?

After losing power (accidentally plugging off RaspPi, grid failure, etc) Octoprint service no longer works.

What did you already try to solve it?

I tried restarting the service with sudo service octoprint restart, I tried running ps -ef | grep -i octoprint | grep -i python and nothing appeared, I tried restarting in safemode using ~/scripts/safemode and rebooting the pi

Have you tried running in safe mode?

Yes. The service cannot start in safe mode.

Did running in safe mode solve the problem?


Systeminfo Bundle

Cannot access octoprint. Attempting to get a bundle via ssh using ~/oprint/bin/octoprint systeminfo results in the following output:

Traceback (most recent call last):
File "/home/pi/oprint/bin/octoprint", line 8, in
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/init.py", line 946, in main
from octoprint.cli import octo
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/cli/init.py", line 289, in
from .user import user_commands # noqa: E402
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/cli/user.py", line 13, in
from octoprint.access.groups import FilebasedGroupManager
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/access/groups.py", line 17, in
from octoprint.access.permissions import OctoPrintPermission, Permissions
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/access/permissions.py", line 11, in
from flask import abort, g
File "/home/pi/oprint/lib/python3.7/site-packages/flask/init.py", line 21, in
from .app import Flask
File "/home/pi/oprint/lib/python3.7/site-packages/flask/app.py", line 34, in
from . import cli
File "/home/pi/oprint/lib/python3.7/site-packages/flask/cli.py", line 33, in
from .helpers import get_debug_flag
File "/home/pi/oprint/lib/python3.7/site-packages/flask/helpers.py", line 42, in
from .signals import message_flashed
File "/home/pi/oprint/lib/python3.7/site-packages/flask/signals.py", line 13, in
from blinker import Namespace
File "/home/pi/oprint/lib/python3.7/site-packages/blinker/init.py", line 1, in
File "", line 983, in _find_and_load
File "", line 967, in _find_and_load_unlocked
File "", line 677, in _load_unlocked
File "", line 724, in exec_module
File "", line 857, in get_code
File "", line 525, in _compile_bytecode
ValueError: bad marshal data (invalid reference)

Additional information about your setup

I'm running the most recent stable versions of OctoPrint (1.6.1) and OctoPi (0.18.0) on a Raspi 3b. Browser/OS are variable, but typically Windows, Android, or Ubuntu on Firefox. Other browsers don't work either.
octoprint.log (71.8 KB)

If the filesystem isn't broken you could try to reinstall Octoprint with

~/oprint/bin/pip install --force-reinstall OctoPrint==1.6.1 --no-cache-dir

That worked! Thanks! Can this command be part of the Octoprint docs? I searched for ways to repair broken Octoprint installs but came up empty. I'm positive I'll need this again in the future, but making this easy to find would be greatly appreciated.

1 Like

Let me see what I can do :wink:

I had this same issue and tried the reinstall, got the following error:

ValueError: bad marshal data (string ref out of range)

Does this mean my filesystem is corrupted?

Bad marshal data is usually some sort of corruption. Was that during the reinstall or when you started OctoPrint? To be able to reinstall you usually have to be lucky that pip/python is not broken and just OctoPrint.

I got that error when trying to reinstall. I can't get octoprint to start - when I check to see if the process is running the PI returns nothing.