[Solved] Raspberry 3B Octopi 0.17.0 WLan does not work :((

Hey there, I tried to get my fresh Raspberry 3B running with the onboard wifi.
I tried it now for several hours and tried a bunch of stuff...I try to break it down simple so that maybe someone can help me out :frowning:

Raspberry Pi 3B
Octoprint 0.17

-I flashed the SD with Etcher

  • edited the wpa_supplicant.conf with Notepad++

Boot --- Wifi?---Nope

Then I tried all kinds of stuff trough SSH in the configs...resulting in confusion and reflashed the Pi with a clean Image...

Using a USB-Wifi Stick didn't help either

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:23:aa:2a  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

thats whats allways showed after ifconfig :frowning:
I searched the internet literally for hours without any result ....

# WPA/WPA2 secured
network={
 ssid="EasyBox-XXXXX"
 psk="passwordXXXXX"
}

## Open/unsecured
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#}

## WEP "secured"
##
## WEP can be cracked within minutes. If your network is still relying on this
## encryption scheme you should seriously consider to update your network ASAP.
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#  wep_key0="put password here"
#  wep_tx_keyidx=0
#}

# Uncomment the country your Pi is in to activate Wifi in RaspberryPi 3 B+ and above
# For full list see: https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2
#country=GB # United Kingdom
#country=CA # Canada
country=DE # Germany
#country=FR # France
#country=US # United States

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

anything else useful I should inform you guys with?

ps.: forgive me, dk why the text is so messed up

Use the </> icon for console output :wink:

Is any other device like your printer connected to your usb port? If yes try it without any connected devices.

Is your power supply sufficient?

Thanks.

Yes a webcam was connected to it (Logitech C270)
My power supply is a normal USB-Cable with a IPhone charger plugged in (1A Output)

I took the Pi this morning to my office an test it with another router, to make it isnt something with my WLAN

Will try it without the webcam aswell.

I guess the charger and the webcam are the problems.
First a phone charger isn't a sufficient power supply


and second 1A is barely enough for the pi itself

2 Likes

hmm you right about that, I never saw it that way...I will try to use something proper for testing in the future

thanks

I used a proper power supply set to 5.1V and tried everything without the cam conencted.

Flashed the microSD new with the latest release.
Edited the config once through PuTTY and once with Notepad++ and only changed the Network settings and the country.

Still no result :frowning: , LAN is ready WLAN is not connecting at all :frowning:

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:23:aa:2a  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
# work!

## WPA/WPA2 secured
network={
  ssid="EasyBox-XXXX"
  psk="XXXXX"
}

## Open/unsecured
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#}

#country=GB # United Kingdom
#country=CA # Canada
country=DE # Germany
#country=FR # France
#country=US # United States

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1


 Cell 03 - Address: E0:60:66:DD:86:DC
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=62/70  Signal level=-48 dBm
                    Encryption key:on
                    ESSID:"EasyBox-XXX"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000000000000000
                    Extra: Last beacon: 90ms ago
                    IE: Unknown: 000E45617379426F782D393339353430
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 03010B
                    IE: Unknown: 050400030000
                    IE: Unknown: 0706444520010D14
                    IE: Unknown: 2A0100
                    IE: Unknown: 32040C121860
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2D1A30081BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D160B080000000000000000000000000000000000000000
                    IE: Unknown: 7F080400000000000040
                    IE: Unknown: DD090010180200000C0000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

Got absolut no clue what the problem is :frowning:

Turns out, my router denied the acces via WLAN to almost every device (thanks EasyBox 804)...its now working properly. I just need to get a stronger repeater to recht my garage with the wlan.
Thanks for helping

1 Like