State: Offline after error No more candidates to test, and no working port/baudrate combination detected

If you run dmesg -w and then unplug and plug in the printer, does anything appear? does the printer appear under lsusb?

[  622.480549] rpi_firmware_get_throttled: 8 callbacks suppressed
[  622.480559] Under-voltage detected! (0x00050005)
[  627.500508] usb 1-1.1.3: new full-speed USB device number 9 using dwc_otg
[  627.600569] usb 1-1.1.3: device descriptor read/64, error -32
[  627.820494] usb 1-1.1.3: device descriptor read/64, error -32
[  628.040501] usb 1-1.1.3: new full-speed USB device number 10 using dwc_otg
[  628.140574] usb 1-1.1.3: device descriptor read/64, error -32
[  628.360502] usb 1-1.1.3: device descriptor read/64, error -32
[  628.480644] usb 1-1.1-port3: attempt power cycle
[  629.140519] usb 1-1.1.3: new full-speed USB device number 11 using dwc_otg
[  629.580509] usb 1-1.1.3: device not accepting address 11, error -32
[  629.680522] usb 1-1.1.3: new full-speed USB device number 12 using dwc_otg
[  630.120522] usb 1-1.1.3: device not accepting address 12, error -32
[  630.120649] usb 1-1.1-port3: unable to enumerate USB device
[  651.600777] Under-voltage detected! (0x00050005)
pi@octopi:~ $ lsusb
Bus 001 Device 008: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I don't know what the printer is :man_shrugging:

BTW: the undervoltage is still there. This can corrupt USB connection too.

Already tried this: ?

Appreciate al the replies!

Thing is, it worked for over 2 years with these cables and power supply... what's new in v3 octoprint causing this?

V3 OctoPrint :question:

1 Like

I tried this and yes, now when I power down the printer the display is not lighted anymore... That better!

I tried some in and out and the printer is now "seen". I am going to print right away I need something and then troubleshoot further...

1 Like

OctoPrint doesn't cause undervoltage. Python 3 doesn't cause undervoltage. Inadequate power supplies, inadequate wiring and back powering cause undervoltage.

I know, but what's the point? I do not care about them... as long as it works... and is did for 2 years stable.

Undervoltage means it works until it doesn't. Now it apparently doesn't. You can try to argue about this all day but the fact of the matter is, undervoltage has again and again been proven to be one of THE biggest reason for a whole variety of symptoms, which is why it should be your utmost priority to fix this when it's being detected. And with "fix it" I don't mean disabling the Pi Support Plugin, but actually fix the underlying problem.

And since fixing the back powering apparently fixed your issue, I'd say you just saw a very good example of how undervoltage can be cause or symptom of a whole range of issues yourself.

I'm not arguing, I agree, but having 3 PSUs of good brands, cables, etc. I can't solve that way, so I need to do else.

So I replaced my PSU with a formal original pi psu and the error about insufficient power is gone. I still cannot connect to my ender 3d pro again... what's next?

The bundle: (60.8 KB)

Please help

Does the printer connect to a PC running pronterface?

And please turn off the DEBUG. It fills the log over 80% - but does not help here.

What is this plugin?

Convert TF to SD (1.0.2)

And this one does not work with Python 3.7:

Instantly after updating octoprint it did not connect anymore... I will try pronterface soon but bet it will... any other thoughts?

You were getting errors in the log about reading from the USB ports previously, are these still occurring? Previously, it was the OS unable to communicate with the USB device. Trying to work out what is broken is key here.

You have 3 things that could be broken:

  • The Pi's USB ports - through undervoltage, damage, etc. they may not be working correctly. Plugging the printer into another device could test if this is the case.
  • The USB cable, swapping the cable with a known working (for communication) cable is the obvious way to test this.
  • The printer's USB port or something else on the printer mainboard. This is probably the most difficult to test, since most people don't have another printer to quickly test with.

Hi, I do very much appreciate all the help and replies!

But why is it so hard to get this: It worked for over a year very well. Even moments before I updated to the latest version of octoprint. I do not believe that an update suddenly broke the physicals... and as linked above, I am not the only one with this sudden issue.
After updating I tried 3 different power supplies, 3 different DATA usb cables and I bought an original raspberry pi power supply, all to no avail of the connection problem.

But a said before, I will rule this out.

Is there any other that I can check from octoprint perspective?

You already checked earlier in the thread with the lsusb command, there were no devices listed. That's a level below OctoPrint, if you deleted OctoPrint from the OS it wouldn't impact the results of lsusb. That's one of your key troubleshooting tools - if lsusb does not show the printer connected, then OctoPrint hasn't got a chance.

You could of course take a backup and reinstall OctoPrint/OctoPi, and test the same things, but I do believe coincidences can happen.

Replaced the board with a 4.2.7 and voila problem gone...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.