Still cant upgrade to 1.7

What is the problem?

Cant upgrade to 1.7

What did you already try to solve it?

Tried the pip update as found on here but still fails and pip is up todate

Have you tried running in safe mode?

Yes, still fails

Did running in safe mode solve the problem?


Systeminfo Bundle (59.9 KB)


Additional information about your setup

On 1.6

error is

ERROR: Command errored out with exit status 1:
command: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-fZamYU/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i --extra-index-url -- setuptools wheel Cython
cwd: None
Complete output (24 lines):
Traceback (most recent call last):
File "/usr/lib/python2.7/", line 174, in _run_module_as_main
"__main__", fname, loader, pkg_name)
File "/usr/lib/python2.7/", line 72, in _run_code
exec code in run_globals
File "/home/pi/oprint/lib/python2.7/site-packages/pip/", line 26, in <module>
File "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/cli/", line 73, in main
command = create_command(cmd_name, isolated=("--isolated" in cmd_args))
File "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/commands/", line 105, in create_command
module = importlib.import_module(module_path)
File "/usr/lib/python2.7/importlib/", line 37, in import_module
File "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/commands/", line 17, in <module>
from pip._internal.cli.req_command import RequirementCommand, with_cleanup
File "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/cli/", line 18, in <module>
from pip._internal.index.collector import LinkCollector
File "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/index/", line 14, in <module>
from pip._vendor import html5lib, requests
File "/home/pi/oprint/lib/python2.7/site-packages/pip/_vendor/requests/", line 43, in <module>
from pip._vendor import urllib3
File "/home/pi/oprint/lib/python2.7/site-packages/pip/_vendor/urllib3/", line 9, in <module>
from logging import NullHandler
ImportError: cannot import name NullHandler
ERROR: Command errored out with exit status 1: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-fZamYU/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i --extra-index-url -- setuptools wheel Cython Check the logs for full command output.
Installing build dependencies: finished with status 'error'
The update did not finish successfully. Please consult <code>octoprint.log</code> and <code>plugin_softwareupdate_console.log</code> for details.

If I run pip update its up to date
pi@octopi : ~ $ source ~/oprint/bin/activate

(oprint) pi@octopi : ~ $ pip install -U pip

DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at pip 21.0 will remove support for this functionality.

Looking in indexes:,

Requirement already up-to-date: pip in ./oprint/lib/python2.7/site-packages (20.3.4)

Have you tried?:


@TTalkington Thank you :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.