Strage Under voltage! even with 5V 4A supply

Hello Im facing Under voltage issues even with 5V 4A supply, figured the issue "dmesg"is not with power supply. How to get rid of it?

can you kindly support.

Here is my system info downloaded from Octopi
octoprint-systeminfo-20220801231615.zidp (60.8 KB)

and Here is where i see under voltage detected from terminal window debug message.

I'm New here and i need to get rid of it.. tried -> "avoid_warnings=1" command also in config file... no use. :hot_face: :sleepy: :roll_eyes:

kindly help in resolving

Hello @Naveen_kumar_Mutthu !

First use cables for the 5V that have a decent diameter. The smaller the diameter/the longer the cable, the greater the voltage loss.

Also, 5.1V is more usable than 5V, for a Pi3 even 5.15 V due to the different power input circuit.

1 Like

Depending on the type of power supply, some are adjustable to change the voltage as well. For example on these types:

Maybe yours is, maybe it isn't, but I thought it would be worth pointing out.

2 Likes

Dears, thank you for response...
Does the error messages convey that the issue is with drop in voltage? can you please confirm once again?
because

  1. my USB cable length is hardly 10 cm.. very short (and with 5V 4A adapter)
  2. i've soldered two additional +ve and -ve thick cables directly to board and connected one more external 5V 2A supply.

if the error messages convey that the issue is with power supply and specifically with voltage then probably i will buy official one.

can someone explain mentioning error messages that this error lead to this failure etc from the LOG image attached?

Thank you for your kind support again. :sunglasses:

Just as a note to back up previous messages. When I first started I had the same problem and my power supply usb cord was a short 10mm (not cm) and I got the warning. Based on what I read as above, sourced some larger diameter wired cord/plug and the problem went away. I read the specs on the cords from various sources and bought the ones with the biggest power supply wiring that I could find.
Problem solved.
Regards

Dears,

im not sure what is wrong with my board. unfortunately nothing works for me. tried all sorts.
including 10mm and with a good power supply.

tried disabling the using -> avoid_warnings=1
even then the issue is still persistent.

any other suggestions or help?

thank you
naveen

I’ve got a similar issue. A 6A PSU and using thick conductors going straight to 5V rails on the GPIO.. just kind of used to ignoring the warning.

Please measure the voltage at the GPIO pins.

There is a self resetting fuse in the input circuit of the Pi3B. Once activated, it has a higher voltage drop.

1 Like

I have the same problem, I just turned off the notification.
But I heared that the RP likes a 5.1v powersupply and that should stop the problems.

You can be sure, the problem will persist.

You get the message when there is s sudden drop below about 4.6V, you can look up the specifics. It only has to be a very brief drop, something you can't measure unless you Oscilloscope is pretty good, mine can only just see it.

It is often a sudden current draw that the PSU responds to and the voltage drops as it tries to compensate.

Many desktop power supplies cannot react fast enough, I know my 100W one cannot.
Also for standard plug in types, many of these drop the voltage as the current increases, again some cannot respond fast enough.

That's after you have you voltage adjusted to compensate for cable and connector loss as it gets to the Pi, hence decent wires.

Things like sudden motors turning on (fans) can cause this.

Harddrive/SSD of course especially Nvme as they are power hungry compared to the old Sata drives, that's more the PSU dropping the voltage as the current nears increases.

If it only happens at boot time and the Pi works, it probably easy to ignore it, just don't keep booting up.
If it happens while using it, then you have a bigger problem.

1 Like

It really is worthwhile just buying the correct Pi power supply.

This way you are guaranteed that it will work without any glitches.

I found that as you add more plugins the Problem got worse.

Changed to the correct supply and bingo, no problems.

1 Like

Dear All

seems there is some serious issue with my board.
i dont see any voltage that is going below 4.7 entire my power cycles, monitored using oscilloscope. plugged my oscilloscope to both 5V rail and RST pin of the 3pin low voltage trigger IC.

even after multiple restarts and power cycles i dont see neither RST trigger nor voltage going below 4.7V across 3 pin IC.

and just for my trail i ve turned off the power supply and from below we can see clearly RST has triggerred by 3 pin IC when voltage goes below 4.6V as intended.

so, it is clear that my supply side there is no issue. but still in Octopi UI i see undervoltage warning. "Under voltage detected from begining of BOOT err 0x50005"

so, i've traced until where the signal goes. and i found the IC below which receives the signal.

R8 value is as intended - 470Ohms
continuity between470ohms and 3pin IC all good.

not sure what IC Is doing with the signal and reporting to the operating system. any suggestions and any datasheet available withanyone?
i tried googling i dont find any data sheet or anything about the IC.

is my board gone?

i wonder why does the error come even after disabling in CONFIG file?

Thank you
Naveen

This topic might have some additional information, https://community.octoprint.org/t/undervolt-icon-regardless-of-voltage/44307.

I had a similar issue powering from gpio.. bought a usb-c connector and still had the same problem until I used the thickest wires that would fit and the message finally went away.