Suddenly octoprint cant upload files (wrong filenames!) solved

What is the problem?
Switched off printer (not Octopi server) at 1AM.
Switched on printer at 9 AM.
Want to upload new file to octoprint, directory shows only special files, when I click all files it shows my just sliced G-code. When I click the file I get the error message as in the video.

What did you already try to solve it?
2 x new SD card and new octopi 0.16 image.
Checked other PI server which behaves the same.
Checked after new image update with and without Octopi update to latest version.
Reset all routers, modems and other network related stuff.
Reboot 3 pc's
Pi wired and Wifi behave the same.
Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)
Logged directly after the video made.
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)
Version 1.3.11
Window 10 pc's
I checked with google for similar problems but there is no exact solution which could solve the issue.

The fact 2 octopi servers behave the same, suspect me it is not the pi server but I am clueless what else could be the problem. The fact when the "open file" screen opens and show "all files" is clicked the c-code file is shown bugs me. (242.5 KB)

Hi @PacoRaap,

have already tried safemode?
Also, where did you download this file. Is it surely a gcode file? In your video, the type declares it as a stereolithography file, like STL In that case, you first have to slice it.

Keep in mind, the the Cura Engine was unbundled with the release of OctoPrint 1.3.11: - New release: 1.3.11

Hi Ewald, thanks for responding.
Your 100% correct that STL files are no G-codes.
I must have had some bad dreams causing me to to se STL as G-code.
Guess what, I sliced a new file from Cura 3.6 and it made a G-code file.
So all working fine again.

Thanks, Paco

1 Like