Target temperature drops to zero after 20-25 minutes of printing

Hello community!
I made my custom D-bot 3D-printer like 3 years ago. And first of all I started to use OctoPrint. And it was perfect until version 1.3.7 I guess when I first get this error. After searching forums for same problems and found troubles like underpower and wrong USB cables, not last version of OctoPrint and tryed solutions from that topics - it not helped. So I tried to use Repetier Server to be shure that it is not a hardware problem - and printer works perfectly. After like 1.5 years of printing I noticed that Repetier develops slowly and don't implement different interesting functions. And now, when I started to develop 2 new 3D-printers I decidet to try again OctoPrint infrastructure for all my projects. So I get another SD card, installed new version of OctoPrint (1.3.12) and... found same problem on my first printer. Another searches on forum was not successfull - still tere are same usb or underpower problems and more new troubles with Creality and other comercial printers that are not my case.

What is the problem?
After preheat procedures and 20-25 minutes of printing target temperature drops to zero and OctoPrint stops print when it get Cold Extrusion error from firmware.

What did you already try to solve it?
Searched on different forums for same problems;
Checked hardware problems like good power supply for Raspberry Pi, good USB-cable;
Using fresh OctoPrint version 1.3.12;
Build TestUnit to check everything twice.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
OctoPrint log file:
octoprint.log (42.7 KB)
Serial log:
serial.log (1.4 MB)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
OctoPrint version: OctoPrint 1.3.12
OctoPi version: OctoPi-buster-lite-0.17.0
printer: Custom D-bot Printer
firmware: MarlinKimbra V4.3.8
hardware: Arduino DUE + Raspberry Pi 3B
browser: Google Chrome latest
operating system: Windows 10 x64
Slicing software: Simplify3D v4.1

Original Screenshot from my D-bot:

Hope together we can find solution because I really like flexibility of OctoPrint and want to use it in my further developments.

Thanks to everyone for any help and assistance!

D-bot itself:

Screenshots from my TestUnit (all parts are same as in my D-bot except it has no mechanics and heatbed, thats why bed temperature set to 23 degrees Celsuis)
Picture like 20 seconds before error report

Picture when OctoPrint reports Cold Extrusion error

TestUnit itself:

And, finally, GCODES:
(Sorry for that - all because of the limitations for new users to upload photos and links)

Original Gcode from D-bot:
2 Swithes Holder.gcode (1.2 MB)

Gcode from TestUnit (all same except for heatbed temperature set to 23 degrees Celsius)
2 Swithes Holder 2.gcode (1.2 MB)

Also got ~1300 last strings from OctoPrint Web Terminal console just in case. Really wanna this problem to be solved.
ConsoleLog.log (43.3 KB)

Thanks for patience!

That's on your firmware:

2019-11-25 15:25:18,031 - Recv: Max inactivity time (30 minutes) Heaters switch off!
2019-11-25 15:25:18,091 - Recv:  T:234.84 /0 B:25.00 /0 B@:0 @:0

MarlinKimbra also sounds familiar in that regard, I remember they decided to demand some kind of "hello, I'm printing now" GCODE or something. Actually added an FAQ entry for that:


Thank you for so fast response!
I'm already starting new printjob with this Gcode additions.
Soon will tell you results.

40 minutes of printing already passed. 30% printed successfully. Seems like it works OK. Tommorow will print more and finalize this issue (I hope so)

I think current problem solved with those magick GCODES, thanks to you, Gina!

But after that another problem occured: Error: Printer requested line 26 but no sufficient history is available, can't resend. After observing few topics in this forum I took ferrit ring and out my USB cable through it. And it solved that issue too! (I really hope so)

Thanks again for help!

1 Like