The OctoPrint server is currently not running after touchscreen install

What is the problem?

I finally got Octoprint running with klipper and everything set up after nothing went as planned. I then tried to install the piTFT 70 from BTT. the screen boots up a showed an SSH screen, but wouldn't show anything else. not sure where to go I tried the desktop which worked, but wasn't what I wanted. I removed it with "sudo apt purge xserver* lightdm* raspberrypi-ui-mods". Now I'm unable to open the octoprint web server.

I don't know anything about coding so this has all been feeling my way through with tutorials I can find online.

What did you already try to solve it?

My thought was to try to reinstall octoprint, but checking the pi with a ftp, everything seems to be there.

Have you tried running in safe mode?

Tried but it's only coming back with "command not found", I expect I'm missing something

Systeminfo Bundle

Again, only getting "command not found" when trying

Additional information about your setup

Printer is a Voron, Octoprint version 1.9.1, Octopi version 0.18.0, browser firefox on Windows

Could you post the shell output including what you typed in?

I'm sorry, I really know nothing about coding and am not understanding what I'm trying to find. How do I generate the shell output to post?

The thing where you got the "command not found" error.
Copy those lines or make a screenshot :slight_smile:

Sorry for the delay,

alright - let me tell you what went wrong there :slight_smile:

in the first line you copied the $ from the example - that doesn't belong there. Then you should replace file with the actual filname.
Same for the second line.
The next two lines are ok, then you just entered a path without any command. If you want to read the file in a tui texteditor your can put nano in front of it.
Next line does the same thing, but with admin privileges.
And then just a filename without any command.

That's the reason why you got command not found - either there was no command or you put a $ in front of it :slight_smile:

Don't worry. Most of us learned the shell commands by ourselves and we didn't know what to do either the first time.

Now let me tell you how you get the logs.
The easy method is to just go to http://octopi.local/recovery and download the systeminfo bundle zip from there. But if that doesn't work you can also create it in the terminal:
Just enter ~/oprint/bin/octoprint systeminfo . (the dot is important) in ssh.

Now download WinSCP, connect to the pi with the same ip/hostname and credentials you used before for the ssh connection.
WinSCP is a file explorer and lets you download the systeminfo bundle you created with the command above.

And the last step is to upload the bundle here so we can look at it :tentacle:

Thank you for holding my hand through this, I need it. Trying the link you sent said that it couldn't open the page.Following the inputs through the ssh gave this response:

It seems that I've run out of space after the desktop install. Could the space be the issue, despite trying to remove it?
Short of clearing the Pi and starting over, is there a good way to filter stuff out that's unnecessary? Or a good way to find the large files to eliminate the biggest files I don't need? It hasn't been used for anything before the printer, so the only thing I can imagine filling it to the brim is the desktop install.

1 Like

looks like it
how big is your sd card? is this an old setup that you just tried to upgrade? could the card be full of timelapses?

There is - but the one I know needs a tool (which isn't, big but when you're already out of space even a small program is too big ^^)

run df -h for me and upload the output. Maybe there was just an issue with the partition resizing at the first start.

The card is an 8 gb. This is a brand new build, but I have had the Pi 4 B for a couple years, just haven't used it until now. If I replace the 8gb with a bigger card, like a 64gb, will that solve the memory issue? I assumed it ran more like a pc with the OS running on the built in memory, rather than the the expandable memory.

The Pi doesn't have any built in memory. The memory mentioned with the Pi 4 version is the RAM size :slight_smile:

In theory a 8gb card should be enough. The normal desktop image from the Pi Foundation is about 4GB.
So either something went wrong, or they downloaded some stuff that you don't really need.

But yeah it would be easier to just use a bigger card so you don't run out of space again in a few months.
Timelapses and gcodes can consume some space (depending on what you're doing).

Imo a 32gb card should be enough, but if you got a 64gb card laying around you can of course use it.

I've swapped to a 64gb, not sure if I can just transfer the files from the previous SD or if I have to go through the entire process again. I've also managed to get the logs, I think. based on the last date it recorded anything, I know that was the day I first started trying to install the Pi TFT70 from BTT. I followed Modbots install instructions from the link below:
"BIGTREETECH PI TFT50 Octoprint Touchscreen Install & First Look - YouTube"

I've attached the logs. Please let me know what I can try

octoprint.log (374.9 KB)

I would really recommend to start over.
We don't know if something broke when you ran out of space.
I know it's annoying, but it's the best thing you can do.

I've been thinking that as well. I tried reflashing a new 64 gb cardwith the pi image, its giving me the same
" The OctoPrint server is currently not running"
If there's no storage on the Pi itself, this step should be straight forward, but it's still not working. Any ideas? Have I somehow corrupted the Pi entirely or something?

I'm wondering if one of the plugins I installed is causing the problem, but I'm not getting any response from my attempts to initiate safemode as I have to do it through SSH, which I have no understanding of. I've tried following the safemode instructions on octoprint's website, but I think it assumes I know more about the console then I do.

Did you get that right after flashing the new image or after you tried to install the screen?

I think I see why the screen isn't working as expected - your guide and the whole OctoBTT installation are 2 years old and meant for on older version of the OS.
Think of it as an guide for Windows 7 and you're running windows 10.

But don't worry the screen uses the dsi connector so there shouldn't be an issue to get it working.

I can't really help you with the screen since I don't have one to test it.

It should be basically plug and play with the latest OctoPi image.
I would recommend to use this as display "software".

I hope someone else with a screen can help you out with the details.

Yeah one of those are probably the issue. We need a current systeminfo bundle so we can tell for sure.
The log from 6 hours ago is 10 days old (at least the last log entry is).

I ended up fixing it by upgrading to a 64gb card and reinstalled everything from scratch like you suggested. Thankfully it went way smoother than the first time. Thanks for your help

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.