The octoprint server is currently not running error

Sorry for the general nature of this request, but I have no clue about most of this stuff. I had Octopi up and running for several months without problems. Today I received a message about updating the Filament Manager extension so I downloaded it and tried to install it. Immediately when I tried to install something broke and I can't reach the octoprint server with either the IP address or octopi.local

From memory I was running version 1.4 I have tried unplugging power and restarting to no effect. I have removed the SD card and verified that the network SSID and password were still correct to no effect.

Here's what I see when trying to connect via IP address, and I have no clue as to what any of this means or how to fix it. Any help is much appreciated.

Hi :slight_smile:

The network part of the pi is working - otherwise you wouldn't see this error message.
Try to get the octoprint.log with the help of WinSCP

The username and password are pi / raspberry

The log is located at /home/pi/.octoprint/logs/octoprint.log

Sorry, it's the other way round:

  • login is pi
  • password is raspberry

@buckeyestargazer
Unless you have not localized the keyboard: Take care if you have a non English keyboard layout, some keys are different located, like z/y on German keyboards. French keyboard are much more different form English ones.

1 Like

Right
My bad

1 Like

Thanks for the reply. I managed to get the log file.

Actually, ignore this. I posted another reply since there was something I spotted in your logs.

Original post :point_down:


There may be some corruption in the OctoPrint install, since pulling power can do that. So can installing plugins occasionally, we also see it with updates to OctoPrint (<0.1%) We can try a force reinstall, but no guarantees it will work in this instance.

The log shows it starting, but then hanging after a couple of entries, lets see what happens.

Can you use SSH, to access a terminal, and then type: ~/oprint/bin/pip install --force-reinstall --no-cache-dir octoprint

Let it run through, then try restarting OctoPrint again (running sudo service octoprint restart)

Don't (at any point, unless it is shutdown properly) pull the power on the Pi, you will only make the problem worse.

1 Like

I spied this line in your octoprint.log, before all the problems began.

2020-09-23 00:40:44,724 - octoprint.plugins.pluginmanager - INFO - Installing single file plugin setup.py from /tmp/tmpDw_VOu.py

What file was this? it could be the one causing problems... You can also try running OctoPrint in safe mode :point_left: to get OctoPrint to not load it. The point at which your log stops is just before plugin initialisation, so this seems likely to me

Thanks. I'm sure this was caused by my stupidity in trying to install a plugin. In this case I was trying to install Filament Manager and not knowing what I'm doing I downloaded the files and from within Octoprint tried to run a file "setup.py"

Can you say more about using SSH, restarting in safe mode and how to correct the plugin not loading correctly (or point me to a tutorial)? I'm not sure how to do anything outside of the user interface.

So the easiest way (probably) for you to do this, is to edit config.yaml as the safe mode link says.

You can find it at home/pi/.octoprint/config.yaml - best if you are you using WinSCP (how did you get the log file?)

There you should (if I remember correctly) be able to edit config.yaml to include the safe mode line, if you want to activate safe mode.

To get rid of the plugin, navigate to /home/pi/.octoprint/plugins and delete the setup.py file from there.

If you want to know more about SSH and the command line, there is loads available on the internet, and its a good skill to have to deal with Raspberry Pi.

2 Likes

Thanks, I got it all sorted out! (I think)