"There was a timeout while trying to connect to the printer" / Prusa i3 mk1 using official firmware

What is the problem?

Timeout immediately after connecting to Prusa i3 mk1 using official firmware.

What did you already try to solve it?

I tried several cables, I tried to reinstall the firmware, restarting the printer and the raspberry pi.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

System information bundle octoprint-systeminfo-20220223150103.zip (63.0 KB)

Additional information about your setup

OctoPrint version 1.7.3
OctoPi version 0.18.0, running on Raspberry Pi 3 Model B Rev 1.2
Original Prusa i3 mk1 1.75 mm running firmware 3.0.12

I am able to run the webcam and I was also able to flash the firmware using OctoPi.

Do you have the 'RPi port' option set to 'off'? (if you are using a USB cable)

I have a MK1. I don't have an option for RPi port.

Sorry, I overlooked that detail! In that case I'm not really sure why it is failing to connect. The firmware responds with some information, but then there is no ok message there anywhere. Something's being dropped in the communication somewhere.

Thank you, @Charlie_Powell for the input.

Since the firmware is quite old (2017), I was thinking of trying to recompile a current version of Marlin and flash it, but I'm first looking at ways to fix things in a simpler way since I can print fine from SD.

I also tried to install Klipper from OctoPi but I did not get very far.

I was able to connect to the printer and print using an older firmware. Seems that I needed the Mini Rambo version, "lite" not "full" Prusa drivers.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.