Timelapse with Timelapse+ with parking feature

What is the problem?

Hi guys! I'm trying to set up my Timelapse+ plugin to make a timelapse video (what a shocker, ehh?), but it seems I'm messing something up. I want the print head to go park after each layers (which I've done in the settings, and it does) and then I want the snapshot to be taken, while it's parking.
Now, it seems there are only two options, a timed snap (every x seconds), and a command snap. So what I did was put @snap command in the gcode after each line change (which of course worked, only it took a picture right when the layer was changing, not when the head was parking, so the print head is in the way, and the same for when I to the snap before layer change instead of after), and then I tried with a timed snap (every 10 seconds), only it didn't park the model/print head before each shot or did any parking at all. So what I'm left with is either a video where I get a picture every 10 seconds with no parking, or a video with a parking head which snaps at the end or start of each line while the head is in the way. What am I missing here?

Thanks in advance!

What did you already try to solve it?

Described it all in the problem above

Have you tried running in safe mode?

No, it isn't relevant.

Did running in safe mode solve the problem?


Systeminfo Bundle

get the system info file off my google drive:
System info file off google drive:

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Anycubic Kobra 2 Neo, Octoprint in windows, version 1.9.3, Chrome browser, Windows 10.

The OctoLapse plugin is designed to do this, I would think that is what you want rather than DIYing it. Have you ever tried it?

The OctoLapse, as far as I can see, doesn't have a "parking feature", only a timed picture or on layer change, which means it will just take a snapshot when the layers change, but it also means the print head will always be in the way of the camera as the printing isn't stopped at all.

Are you sure you're looking at the right plugin?

Obviously I wasn't looking at the right plugin, I tried to install this plugin from the plugin manager but it give me errors:
Install log on my google drive:

There should be no problem to upload your files here.


Well, live and learn, this is the first time I'm using this forum.
File uploaded, and thanks!!
Octolapse error.zip (28.5 KB)

Windows install with the packaged installer?

I think to install Octolapse you'll need Visual Studio Build tools since it builds some libraries it needs to work. @jneilliii would be able to confirm but I believe if you follow the 2nd step in the manual install to get the build tools, it should work.

1 Like

Yeah, that should work. I thought I had got the build tools bundled properly in some of the latest installers, but I guess it's not working as expected.

1 Like

@Yuval_Lahav did you install on a windows 10 or windows 11 machine initially and do you happen to remember when you downloaded the installer?

To resolve you can go into C:\OctoPrint\ (whatever path you used to install OctoPrint) and double-click the file vs_BuildTools. Once loaded click the modify button, and check the box for windows 11 SDK

Once completed OctoLapse will install without error.

1 Like

Yes, I installed it with the windows installer. I'm off to work right now but will try the guide second step as soon as I get back this afternoon, thanks!

I installed it on my windows 10 machine (alas it's too weak to support windows 11 upgrade...), I only just installed it last week, so it was the latest version of the installer.

Thanks for taking the time! I'll try all these steps once I'm home today after work!
I'll keep you updated if and when it worked (or not).

1 Like

It worked! The plugin is installed, and now I'll be able to go and play with it.
Thank you for the quick and helpful response (and I'm glad this helped to get something that was overlooked set in order!).


not quite overlooked, but definitely something that changed from the MS side. I think when the Windows 11 SDK was released is when maybe it stopped working properly. I made some tweaks last night to the installer that should help resolve it, thanks for the confirmation.

1 Like