Touch UI - Can't Login

Not sure what the issue is, but Touch UI will not accept my password. I can log on to octpi.local without any issues using the same name/password. I have done it a few dozen times, even wiped the sd card, and started octoprint luck.

1 Like

Rebooted and now getting a browser error console, startup failed. The logs have this at the end....

2020-11-25 22:53:47,933 - tornado.access - WARNING - 403 GET /api/settings (::1) 49.21ms

1 Like

Not sure what I did, but I am back at the login screen for TouchUI. However, it is still not accepting my OctoPi password. Not sure what else to do....

Hello @mikecoscia!

Keep in mind that the OctoPi password and the OctoPrint password are different, as OctoPi and OctoPrint are not the same:

Does the Touch UI accept any inputs?

Thank you for responding and Happy Thanksgiving!

Pretty sure I am using the correct name/password. It is the same one I use to login into octopi.local.

The screen is 5" and uses the DSI cable. It detects my finger, as I can see the cursor, and I can type in the text fields.

I followed this guide...

So...I tried installing TouchUI before upgrading OctoPrint from 1.3.12 to 1.4.2 and the TouchUI dashboard actually showed up and was usable for a minute or two! Then it went right to the startup failed. I tapped to retry and it never loaded up again. Just stuck at connecting to TouchUI.

Check this is not the issue:

I did come across that screen after a fresh install of OctoPrint and TouchUI. I tried the suggestions in that thread, but no luck. The closest I have gotten was when I was running OctoPrint 1.3.12. At least I had the TouchUI up and running for a minute or two before it failed again. I even tried installing on a Pi2 I had lying around, which was connected to the official Raspberry Pi 7" screen.....same issue on that one as well.

Are you using the TouchUI AutoStart stuff? The only way I did it was to do it myself, with an autostart service. I have heard from being around here that it is not the easiest thing to get going.

I personally struggled to get TouchUI to run well on my Pi, everything was quite slow and quite hard to use. I was much better of with OctoDash, maybe you might want to try it as an alternative:

I'm also seeing this... Trying to use a raspberry pi 3b with Touch-UI-autostart with a fresh install, but am also getting this issue... Happy to provide forensics...

I did follow the boot to browser instruction listed here..

I also tried adding in the localNetworks to the config.yaml. Nothing I did worked or only partially worked. I just can't figure it out.

I tried OctoDash as per your suggestion and was able to get that up and running without a single issue.

1 Like

same issue here. after a LOT of trouble, I'm stuck at the login screen. I'm using the Octoprint user and password. a wrong password gives me the "wrong password" error, the correct password just reloads the page. there's nothing interesting in the logfile:

020-12-22 12:47:48,591 - octoprint.access.users - INFO - Logged in user: teus
2020-12-22 12:47:48,597 - octoprint.server.api - INFO - Actively logging in user teus from ::1
2020-12-22 12:47:48,811 - octoprint.server.util.sockjs - INFO - Client connection closed: ::1
2020-12-22 12:47:49,068 - octoprint.server.util.sockjs - INFO - New connection from client: ::1
2020-12-22 12:48:03,344 - octoprint.server.util.sockjs - INFO - Client connection closed: ::ffff:

I had the same 403 error and got around it by disabling ipv6 and removing the ipv6 settings from haproxy. I'm not sure what the underlying issue is, but ipv6 has certainly been a pain for me elsewhere. Adding ipv6.disable=1 to the end of the single line in /boot/cmdline.txt will do that (It's recommended to make a backup of the file before doing this, and keep in mind if you have a typo stopping boot you can plug the SDCard into a computer and modify the file from there).

As for haproxy, you will need to change the lines in /etc/haproxy/haproxy.cfg that correspond to the following:

        bind :::80 v4v6
        bind :::443 v4v6 ssl crt /etc/ssl/snakeoil.pem


        bind :80 v4v6
        bind :443 v4v6 ssl crt /etc/ssl/snakeoil.pem

to continue to access the web services externally.

1 Like

And again ipv6 seems to mess up everything. This solved it for me.