TP Link Tapo Smart Plug not connecting to Octoprint

Hi All, i have an ender 3v2 Running Octo Print and a TPLink Tapo Smart plug to the printer which has been turning off my printer when the print finishes, but unfortunatly now all i get is a grey symbol spinning for the smart plug in octoprint where as before it would not spin and be a bright green to say its connected. has anyone else suffered this issue lately?


Hello @m999 !

What plugin do you use for the smart plug and where has this gone?:

What is the problem?


What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support! )


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, .... as much data as possible


Hi thanks for the reply, I am using the "Tapo Smartplug" Plugin and i have labeled it as" Ender 3 main" i have installed a couple of others but they are not working either. it just spins around grey and wont shut the printer off anymore, cheers

I can't find it in the OctoPrint repository.

Where did you get it from?

And again:

I suspect it's this fork of my plugin....

1 Like

Hi thanks for the reply, i have tried to manual install but it says install unknown?

You might want to try this forked version (there's an open PR with a fix).
1 Like

thanks ill give it a try :slight_smile:

Hi Its still the same unfortunately

we think we worked through the issue here with the Tapo plugin. The problem stems from the upstream module forcing a requests module version that is incompatible with OctoPrint. You can try installing my modified version of that module by running

/home/pi/oprint/bin/pip install

prior to installing the plugin. That way the module dependency is satisfied and doesn't conflict with OctoPrint's minimum version requirement of requests. I do not know if this will actually fix the issue, but it should at least allow you to get the plugin installed and check yourself.

potentially found a simpler solution. someone forked the original plugin and module dependency and has put them together, so you may be able to just use this URL to install.
1 Like

thank you ill try now :slight_smile:

Still no joy im afraid

system info bundle may help diagnose the error then.

1 Like

thanks ill give it a go :slight_smile:

its says
2022-03-10 17:12:18,098 - octoprint.server.api - ERROR - Error calling SimpleApiPlugin taposmartplug
this pops up alot


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.