Trouble with USB connection

What is the problem?

Today I installed the 1.1.5 Silent Motherboard from the official Creality store and also tried to setup Octoprint with a Raspberry Pi 3B+. Octoprint seems to be running fine and I can connect to the web visualization just fine, but as soon as I connect the Pi to the printer with a USB cable, the printer randomly starts clicking as if I pressed the control wheel. Furthermore Octoprint is unable to connect to the printer.

What did you already try to solve it?

I've already tried different cables and restarted both the Pi and the printer, which didn't change a thing. I've also tried taping over the 5V pin on the USB cable as it seems to cause a multitude of problems. Neither helped and I couldn't find any other solutions related to my problem.

Complete Logs

The browser interface of Octoprint gives me the status "Error: Failed to autodetect serial port, please set it manually."

Additional information about your setup

I use an Ender 3 Pro with the official 1.1.5 Creality Motherboard. OctoPi 0.17.0 runs on a Raspberry Pi 3B+.