Trouble with USB connection Ender 3 Pro v2

What is the problem?

I have already filed a ticket, without any response: Trouble with USB connection

What did you already try to solve it?

In the meantime, I've tried updating Octoprint to v1.4.2, which didn't seem to do anything.

Complete Logs

Demonstration here: https://i.imgur.com/722WNW3.mp4
Since the last post, the error message in the web interface has changed to "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)"

Additional information about your setup

OctoPrint v1.4.3
OctoPi 0.17.0
Raspberry Pi 3B+
Ender 3 Pro
1.1.5 Creality Silent Motherboard

That's weird.
I guess you already tried another usb cable?
Try too look inside the printers usb port. maybe there is a bent pin

Using a different USB cable produces the same problem. From the outside, it also doesn't seem like anything is wrong with the pins.

Did you try to connect the printer to your pc / mac ?
Just to rule out the pi

I don't think that would be possible without more effort than it's worth.

Is there any other option than 'AUTO' in the connection box? If there is nothing, then the Pi cannot see the printer. If there is something, then that is one step done

The video of the screen in your post does not look good. I'm guessing it works normally (no OctoPrint), I would be tempted to say that's an issue with the printer's control board.

Maybe you want to share the

Complete Logs

as the post template suggests? At an absolute minimum looking at the terminal tab would help, although serial.log is preferred

There's been several reports of this lately it seems from the same printer. It's really starting to sound like a problem with either the design of the board or some other firmware related glitch. Below link is an example.

Maybe it would be smart for all you guys to keep your posts together for better troubleshooting...

1 Like

Just a thought but do you turn on the printer first before the pi? The Ender 3 v2 doesn’t like the pi providing 5 vols down the usb cable.
When I have had a problem with connection to a pc I have found connecting to a iPad first usually resolves the issue

It doesn't matter which order I turn them on in and I've tried taping over the pin, as someone else had suggested.

Out of desperation, I went ahead and bought a couple extension cables just to try this out. When connecting it to my Windows 10 PC it simply does nothing. I can't see the printer in Cura, I can't connect to it in the Arduino IDE to update the Firmware as someone suggested and when I go into the device manager, it only shows 'COM1' under ports. Is there a step I'm missing or could it simply be that the mainboard is defective?

What length did you approach?
Keep in mind that a USB2 connection should not exceed 5 m:

  1. Do you realy use an USB DATA cable or maybe just a USB power cable? There are many Power cable in usage and only a view data cable. You can't see what type is is. Maybe buy a specific data cable!
  2. Close all other applications on your PC which maybe will use a serial connection. (No CURA or any other slicer or Printrun (Printerface) should be open in the background!)
  3. Use 115200 Baud or check with 250000 Baud
    ( Serial Port: /dev/ttyUSB0)

Hello @Quack !

I'm the happy owner of a Ender 3D pro which I like to call a V2 because it came with the motherboard of a v2. I'd be silly to give you advice regarding my own experience without checking we actually have the same hardware, so I have to ask : what made you call your Ender 3 Pro "a v2" ? The post you linked deals with a 1.1.5 card, which is a 8 bit. The motherboard I have is a 4.2.2, which is a 32 bit card. As far as I know, Octoprint works with both, but I don't want to tell wrongly that we share the same hardware if we don't.

After many troubles with EMI, I finally managed to connect my printer with Octopi. I've troubleshooted all of this here. My solution was, finally, to power the Pi from the Printer, and to put some strap on the USB cable as you mentionned.

I still have a question, just to be sure I understand the workflow. The screen you share on your initial post is really messy. When you plug the USB, the screen goes from a normal ender 3 screen to this messy-full-of-noise one ? When you don't plug any USB, the screen is clear and you can make clean print from the SD Card, right ?

Cheers,
K

I tried with a 1,5m USB extension and after that didn't work, moved the printer right next to my PC and only used power extension cords.

Don't all USB cables have the same standardized 4 pins? As for applications, I restarted my PC multiple times, it shouldn't have an impact. And shouldn't the device manager show something, regardless of the baudrate?

The printer works perfectly fine, unless I connect the Raspberry Pi to the printer, which produces the seemingly random artifacts in the video. Connecting my PC to it on the other hand does absolutely nothing.

What do you mean by powering the Pi from the printer? Soldering the Pi's power supply cable to the internal pins of the printer's PSU?

Yes, 4 Pins but many have only internally connected +5V and Ground but not the 2 data lines. I often had that problem when trying to connect Arduino´s to the PC using Arduino IDE; no connection...

1 Like

Hi @Quack :slight_smile:

Yep, USB cables are standard in connector's shape but not all are equivalent in the connection. Some uses better cobbler than others, shielding may vary too and, as @Hartmut_DK5LH said, some cables have only 2 out of 4 internal cable (the + and -, not the data line). Some are charging cables, others are data cables …

It goes the same with power source unit for raspberry pi. Some are better than others. I've tried using official power source for raspberry pi but it did not work so what I did at the end is, as you said, soldering a small circuitry (namely, a LM2596) to power the pi from my printer (note: I'm a total rookie in that, and still it was very easy). It was not about modifying the printer, actually – I didn't have to unscrew a single screw of the printer, I used a Y-shaped XT60 cable, if you wanna look on the net ;). "Chargers" sold on Amazon are generally cheaper than real power source units (which have to be precise in their current delivering; a USB charger does not really have too, I learnt).

But first things first, I'd probably try to get the connection to a computer working. I'd probably try different USB cable on a standard computer until I get a serial line to the printer, to rule out the raspberry pi.

You're a life saver. Out of the three cables I tried before none apparently were data cables, but knowing that the difference exists, I found the thickest (and unfortunately, also the shortest) cable I had lying around and using it, the connection works perfectly fine.

I then tried connecting the Pi to the printer with it, which resulted in the same artifacts as before. So, I once again taped over the 5V pin, as I had done with the charging cables and the artifacts disappeared.

I can now control the printer via octopi, as should be, BUT the printer still randomly clicks through the menus while the Pi is connected. I think I will try to update the firmware again and hope for the best.

1 Like

I can't get it to work since I get an 'not in sync' error from avrdude everytime I attempt to upload firmware, no matter whether via the Raspberry Pi or my PC. No idea what causes this and I can't seem to find a working solution for it on the Internet.

The clicking also remains and is starting to drive me nuts.