Unable to Connect Ender 3 Pro with SKR Mini E3 V2.0 to Octoprint

What is the problem?

I am unable to connect my printer to my Raspberry Pi.
The Raspberry Pi is a Raspberry Pi 4 Model B 8gb
The printer is an Ender 3 Pro
The board for the printer is the BTT SKR Mini E3 V2.0
The LCD for the printer is the BTT TFT35 E3 V3.0
There is a antclabs Bltouch attached to the printer
The printer operates normally with marlin and prints fine

What did you already try to solve it?

I have tried 3 different power supplies: 1 with an output of 3.6 - 6.5 V 3A, 1 with an output of 5.0 V 3A and finally one with an output of 9 V 3A
I have recompiled my own marlin firmware starting from the github default base with the build environment set to STM32F103RC_btt
I have used the marlin examples for the Ender 3 Pro with the SKR Mini E3 V2.0
I changed the values SERIAL_PORT and SERIAL_PORT_2 with different combos of -1,0,1 and 2
I tried the Serial exception work around adding dwc_otg.speed=1 to /boot/cmdline.txt
I have put a strip of tape on the 5V pin of 3 different mini b usb cables (I've ordered another one just in case all the others were faulty too but it won't arrive till late next week)
I have tried disconnecting the TFT35 and using the original LCD + no LCD
I have tried using the most up to date version of Octoprint and Octopi (the 'logs indicate a slightly older version as this is the one that the imager installed on them.

'Logs (/var/log/webcamd.log, syslog, dmesg, ... no 'logs, no support)

octoprint.log (16.5 KB)
serial.log (2.7 KB)
terminalOutput.log (49.3 KB)

Have you tried running in 'safe mode?


Did running in 'safe mode solve the problem?


browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.63 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 8204619776
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2

I have added apostrophes to some words as Markdown was auto hyperlinking them and I wasn't able to post.

on your pi!?
are you sure you didn't fry it?
did you test other usb devices to make sure it still works?

1 Like

I decided to double check this just in case I had fried a controller or something else as I haven't connected anything else since my first attempt.

I connected a Logitech C615 HD webcam and a Sandisk 32gb cruzer flash drive which both worked fine with the pi and the webcam even showed up correctly in the octopi.

Right now I think it may be me doing something wrong with the way I've written my firmware or there may be a physical defect on the board.

I did also try my old creality board recently and it was detected by Octopi and controlled my printer straight away, the only down side with it is the stepper motor drivers suck and it make a lot of noise.

SSH into the Pi and try the following commands:

lsusb - different combinations, with nothing plugged in, then the working board and not working board and compare changes. You should see a relevant USB device appear when you plug the board in. If you see nothing when the new board is plugged in, then it could be faulty.

Try also dmesg -w, then unplug and replug in the board. You should see some messages relating to the new USB device but hopefully no errors.

Edit: and don't try and power your Pi from anything other than a 5V supply, you will definitely risk frying it. They do come with a resettable fuse but this will not protect against much.

I went ahead and tried this out and have attached the logs. I first did a baseline with nothing connected then I tried my Creality 4.2.2 board which connected to octoprint straight away and then I tried my BTT Skr Mini E3 V2 which presented the same timeout errors as earlier.
skrMini_E3_V2.log (48.8 KB)
crealityBoard_4_2_2.log (46.0 KB)
noDevices.log (42.5 KB)

Additionally I have contacted BTT support to see if they can help, but they have not provided any response.