Undervoltage indicator

What is the problem? Not sure it is a problem, but at the top of my screen is the non-blinking black icon for undervoltage. Is is only an issue if the icon is red and/or blinking?

What did you already try to solve it? Ask you guys

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...) NA

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...) NA

I've only had this icon showing when there is an under-voltage condition. Otherwise, it is not visible
Fixed my issue with a better 5V power supply.

Hi @petey!

Just look here: Pi Undervoltage/power issues: I had a strange lightning bolt/temperature symbol with an exclamation mark popup in my navbar, what does that mean?

That's my point; the popup says the undervoltage is shown in red. Mine is black and not blinking. Do I have a problem?

That means, that the undervoltage occurred before. It disappears when you restart the Pi and the undervoltage issue does not happen again. If it occurres more often, you should check your power supply and cables.

I had the same problem when I first setup my Pi. It was black which as noted indicates a previous event, In my case, I ended up replacing the lead from my power supply to the micro usb connector with a better quality piece of wire. The original was from a cheap usb charger and the one I bought was a much thicker gage wire.
Problem solved as I haven't see the icon since.

Country Bubba


I had the dreaded undervoltage indicator appear recently on my pi. I suspected my hand built power cable (I needed bare leads to use my DIN mounted PSU), well, since I built it myself. I purchased a 22awg cable, and the problem did not go away. I replaced my PSU and the issue vanished. I'm still not sure why my 40W psu isn't working anymore. I need to put a meter to it and figure it out.

The moral of the story: Even if your PSU and cable have worked in the past, that isn't a reason to rule either of them out as the problem.

Do you have themify enabled? For some reason the 'warning' indicators are gray in some of the themes. I added CSS to my plugin to counteract this, since the warning icons are pretty important to me :slight_smile:

Looking in the output of DMESG, i see during boot there is a very momentary voltage issue and a line or so later it says voltage normal. Just because there was enough of a blip to trigger the alert does not mean there is an ongoing issue. Octoprint is an active and interactive application and should have the sense to see that it was normalized and turn off the dang indicator.

OctoPrint isn't generating this warning. Your Raspberry Pi is. OctoPrint only makes it visible. If there is an issue, even just briefly during boot, then there's an issue that you need to fix. Don't blame the messenger telling you about your power supply being out of spec, fix the power supply situation.

Since setting up octoprint on my pi 3b ive had the stupid undervoltage issue, i have the pi running through the power supply of my printer, i have a buck converter running 5v 4a as i had to tweak it to try and get rid of the problem its still there in black flashing. Ive got a heavy duty power lead bought soley for this purpose. Tried running threough usb plug in socket same response tried usb lead in powersocket with usb same response. Dont have a power supply for the pi as never needed it until this . I cannot upgrade the program or add ons due to this and dont know what else to try. Printer and octoprint working absolutely fine been on solidly for over 3 weeks with little break on mammoth printing mission for a friends dalek.
running ender 3 with raspberry pi 3b

Even the buck converter can deliver 4A, then power supply of the printer is not an infinitive power source.
If all heaters are on and the steppers are in full action, this voltage can drop too because the printers power supply reaches the limits of it's capabilities.
One of the reasons to use a separate power supply (not charger) for the Pi.

ok thanks still doesnt explain why when plugged into the socket it doesnt work as sockets usb is 5v 2.1amp

For the Pi 3B the recommendations for the USB power is: 5.2V 2.5A
The is a self resetting fuse in the power input circuit.
One it has been activated - this can happen when working with the GPIO - it has a slightly higher voltage drop.

With a drop here, another there and another other elsewhere, it can make the undervoltage circuit trigger.