Unsupported Board type error Raspberry Pi 4 Model B

Hello, I've been fervently trying to install octoprint into my new pi 4 b that delivered yesterday from Adafruit. I have followed the standard procedure of raspberry pi imager using ctrl+shift+x. I have also tried loading the img itself and editing the supplicant file for my wifi. No matter what I do I get 4 long and for short green flashes, which apparently indicates an unsupported board type. I am using the latest version of Octoprint. I am at the limit of my tech knowledge and don't know where to go from here. Does anybody know how to fix this?

i am having the same problem
in the end i put the highly experimental 64bit nightlies on and that worked dont no why

Do you have 2GB? That's what I'm using.

For anyone having the same problem: The latest nightly build for the 32bit version actually worked for me and I can connect locally.

Thank you so much for the reply you saved me many hours.

Now it is working, please run cat /proc/cpuinfo and let us know the revision field. It should be something like c03112. This is the second (well, two reports in one so 3rd) report of this this week, looks like a new image might be needed.

Please test the nightly build well and let us know if things don't work - then fixes can be applied and a new image published as soon as it is ready.

FYI - Last August I installed Octoprint on a Raspberry Pi 4b with 8GB and it worked first time.
I know nothing about programming and just followed the steps on the site.
The site asks if you want to enter your wifi info and I did.
Wrote to the SD card and inserted it into the pi and ran first time with my Ender 3 Max.
Don't remember what version of Octoprint that was but I'm just saying that it can work on a 4b.

Our assumption here is that Raspberry Pi Foundation has released a new revision version of their board that requires a more recent base OS than what is currently available on the stable octopi 0.18 release. This happened before when the original Pi 4 was released.

Where exactly would I input this? Sorry pretty new to the Pi business.

Additionally, I am sometimes disconnecting from octoprint and am unable to reconnect without reboot. I'm not sure if this is due to using a nightly build.

FYI, I've added a heads-up about this to the download page, should be live soon. Currently refers affected users to the 32bit nightlies.

It would be on the command line, accessed through SSH. It's not really necessary, it would just be nice info to know on our part.

I'm looking into a small minimally invasive adjustment to the image via CustoPiZer to see if we can solve this quickly for everyone currently affected and then do a proper release cycle for OctoPi without the added stress of this situation.

I would need someone with an affected RPi4 to flash an image I'll prepare and see if it boots. Would either of you be up for that @Skull or @ba33a?

edit Test image can be found at

Download the zip, unzip it, then flash with RPi imager. Would be good to know if it boots on a Pi that refuses to boot stock OctoPi 0.18.


Thanks a lot!!

My Pi version:

stock image didnt work for me, test image above did

1 Like

As @Charlie_Powell suspected a new rev version for the Pi 4.

The new image with uploaded kernel and bootloader is now available in the Raspberry Pi Imager and via the download page.


I, too, am having no luck with installing Octopi. I have a new Pi 4 (4gb version). I can boot it up using the regular Pi OS (using the Raspberry Pi Imager) with no issues, whatsoever. ANY version of Octopi will not boot. At best, I get a flashing, black screen. I've tried using the Imager and doing it manually (file zip, etc.)...nightlies and the stable version. Octopi is the only reason I got the Pi, so it's a bit frustrating. Thanks for listening!

Do you get the 4 short 4 long flashes from the green LED on the board?

No. At first, it all seems normal - irregular green light action...so it looks like it's writing to the Pi. After a minute, or so, I just get a single, green flash (with red on the whole time) every once in a while.

That seems like it would be a different issue to this one with unsupported new hardware, which has a definitive error code. Those flashes seem to indicate the Pi is booting somewhat.

To be clear, did the stock OctoPi 0.18.0 image work for you with that Pi4?

For general reference, I have two Pi 4 boards (one purchased recently [mid-November?], one purchased at least a year ago) that the 0.18.0 image worked on without any issues:

Older Pi4 1GB:

Hardware        : BCM2711
Revision        : a03111
Serial          : 10000000e1ac49a0
Model           : Raspberry Pi 4 Model B Rev 1.1

Newer Pi4 2GB:

Hardware        : BCM2711
Revision        : b03114
Serial          : 10000000f2623af5
Model           : Raspberry Pi 4 Model B Rev 1.4