Update octopint 1.8.0 fail

What is the problem?

The version was updated several times ,but failed

What did you already try to solve it?

update and restart times,still failed

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

[octoprint-systeminfo-20220518185103.zip|attachment](upload://1T25q8EMcHcUQ3Wwtmda9ghpQ1d.zip) (66.3 KB) You can download this in OctoPrint's System Information dialog ... **no bundle, no support!**)


Additional information about your setup

sea "octoprint-systeminfo-20220518185103"
update20220518.log (11.4 KB)

This is your issue:

Have you tried restarting the server? The update may have worked in the background but it is not able to report that it worked correctly. Otherwise follow the instructions above to fix it.

Well I just upgraded to 1.8 and it runs once but now won't run at all. I tried SSHng into it and it isn't logging anything new, nor is it a listed process,,,

You could try to reinstall it

Can I restore the original G-code files and plug-ins after reinstallation?

Reinstalling OctoPrint using the post above doesn't impact stored data etc. so that should be fine.

1 Like

I tried reinstall Octoprint with
~/oprint/bin/pip install --force-reinstall OctoPrint==1.8.0 --no-cache-dir
but, error happen
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
awesome-slugify 1.6.5 requires Unidecode<0.05,>=0.04.14, but you have unidecode 1.3.4 which is incompatible.
Successfully installed Babel-2.10.1 Click-8.1.3 Flask-Assets-2.0 Flask-Babel-2.0.0 Flask-Login-0.5.0 Jinja2-3.1.2 MarkupSafe-2.1.1 OctoPrint-1.8.0 OctoPrint-FileCheck-2021.2.23 OctoPrint-FirmwareCheck-2021.10.11 OctoPrint-PiSupport-2022.3.28 PyYAML-5.4.1 blinker-1.4 cachelib-0.2.0 certifi-2022.5.18.1 charset-normalizer-2.0.12 colorlog-6.6.0 emoji-1.7.0 feedparser-6.0.10 filetype-1.0.13 flask-2.1.2 frozendict-2.3.2 future-0.18.2 idna-3.3 ifaddr-0.1.7 importlib-metadata-4.11.4 itsdangerous-2.1.2 markdown-3.3.7 netaddr-0.8.0 netifaces-0.11.0 pathvalidate-2.5.0 pkginfo-1.8.2 psutil-5.9.1 pylru-1.2.1 pyserial-3.5 pytz-2022.1 regex-2022.4.24 requests-2.27.1 sarge-0.1.6 semantic-version-2.9.0 sentry-sdk-1.5.12 sgmllib3k-1.0.0 tornado-6.1 typing-extensions-4.2.0 unidecode-1.3.4 urllib3-1.26.9 watchdog-1.0.2 webassets-2.0 websocket-client-1.3.2 werkzeug-2.0.3 wrapt-1.13.3 zeroconf-0.33.4 zipp-3.8.0 zipstream-ng-1.3.4
WARNING: There was an error checking the latest version of pip.

Octoprint is not updating because the awesome-slugify package got dependency conflicts.

It's probably used by Octolapse. The easiest way would be to uninstall Octolapse, update OctoPrint again and then reinstall Octolapse.

I'm having the same issue. My upgrade from 1.7.3 to 1.8.1 "worked" but then octoprint failed to start with all sorts of python errors. So I'm trying to re-install steps but it's failing due to unidecode and slugify. How can I remove the octolapse plugin if octoprint isn't running? I guess I'll try to uninstall slugify and see what happens.

edit heh, answered my own question ... used pip to remove octolapse and was able to reinstall octoprint 1.8.1.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.