Update to 1.7.3 from 1.6.1 is failing

What is the problem?

Update to 1.7.3 from 1.6.1 is failing

What did you already try to solve it?

Removed all third party plugins and also tried updating in safe mode

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.88 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 971055104
env.os.bits: 32
env.os.id: linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x50000
env.python.pip: 19.3.1
env.python.version: 2.7.16
env.python.virtualenv: true
octoprint.safe_mode: true
octoprint.version: 1.6.1
printer.firmware: Marlin TH3D UFW 2.13 (Dec 10 2020 15:21:33)
systeminfo.generator: systemapi


Additional information about your setup

Pi does have a touchscreen installed running OctoDash - Innomaker Raspberry Pi LCD Display TFT Capacitive Touch Screen 3.5


Hello @3dKaos3d :blush:
You may have a look on this thread


1 Like

does not look like that person on that thread solved their issue from what I can tell.

octoprint-systeminfo-20220418141543.zip (98.4 KB)
Here is the bundle sorry about that.. first time I had issue with it .

The thread is marked as solved.
At the end of the first post there is this:

So the issue was going to Python 3...

I am not quite sure how to do that.

This is your issue, from the logs in the bundle:

It is an issue that only affects legacy Python 2 installs. For upgrading to Python 3 (as the many blog posts & notifications have mentioned, and which you will have to do to upgrade to 1.8.0), you can look here:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.