Updatingfrom very early Octoprint

Filling this out properly makes it WAY more likely to get help quickly ~~~~~ -->

What is the problem?

I am currently using Octoprint 1.16.1, with Python 2.7.16 and Octopi 1.17.0
I have had good experiences with this setup but see that I am well behind the current versions.
I am always wary of updating because of possible hicoughs that leave one with a mess and unable to get back to the setup that worked.
I am not comfortable with coding and easily get lost so generally do not update.
If I do try to update to latest setup versions am I heading to frustrations best ovoided?
All help will be appreciated/

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.16.1, with Python 2.7.16 and Octopi 1.17.0[date=2023-02-28 timezone="Europe/London"]

To start with, you will need to upgrade your Python version first to be able to update to 1.8.x versions, since your Python 2.7 is no longer supported.

See the below post for instructions for that:

I would probably recommend re-flashing OctoPi as the fastest way to get up to date. 1.6.1 is not that ancient (less than 2 years ago) so I wouldn't anticipate too many issues as the jump is not that huge.

As always - take a backup of your stuff first before doing large upgrades so you can go your data back is something goes wrong.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.