πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Webcam not working in control tab

What is the problem?

Webcam not working in control tab from a remote computer, but works if I put the address in a separate tab in the browser.
The webcam on control tab is working on the local Raspbian.
In settings the snapshot test works ok but not the stream test.

What did you already try to solve it?

Tried to put the user:password@ in the address, but no success...

Have you tried running in safe mode?

Nope

Did running in safe mode solve the problem?

Nope

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE

Several questions:

  • What is the stream URL?
  • Are you using basic auth then?

  • How are you accessing OctoPrint (what URL etc.)

  • What happened to this bit of the post:

The stream address: http://192.168.1.37:8080/?action=stream
Like i sad, if I paste this address in a new tab in chrome it works (also in remote computer on my home network), but the same address inside Octoprint doesn't (Control Tab)

octoprint-systeminfo-20220509190919.zip (25.9 KB)

Since you are not using OctoPi we need to know how you have setup the webcam. You should aim to provide as much information about your setup as possible. In addition to a couple the questions I already asked.

I had problems like this, but I tried to use a usb camera and there were other old versions, I accessed it directly through the ip, but not through the octopi, the address was wrong

try this
"/webcam/?action=stream"
or "127.0.0.1/?action=stream"
I saw in the logs that it has an error when accessing ip .1.37

"2022-05-08 19:02:02,598 - zeroconf - WARNING - Error with socket 5 (('192.168.1.37', 5353))): [Errno 101] Network is unreachable"

my configs

Thanks for replying, but the "/webcam/?action=stream" could never work from another computer which is part of my problem:
using the following address to the camera http://192.168.1.37:8080/?action=stream:

  • The webcam work ok from the Octoprint Control tab on the local Octoprint computer.
  • The webcam work ok from another computer in a separate google tab.
  • The webcam does not work from another computer in the Octoprint Control Tab

Have you missed the several times I've asked you for details of how you've setup the webcam stream and how you are accessing OctoPrint? Or just choosing to ignore them?

Thank's for your attempt to help me. I got it working by accessing it by my external internet address and a port forwarding in my router. Still not understand why it didn't work with the LAN address...
So using "http://192.168.1.37:8080/?action=stream" didn't work but
"http://myexternalip:8080/?action=stream" and a port forwarding to 192.168.1.37 worked...

I'm afraid this will work for those guys too, that sniff the Internet for forwarded ports to break in. For a test maybe ok, but not on the long run.