Webcam stream not working in OctoPi

Camera model

Microsoft Lifecam HD-3000

What is the problem?

I get no webcam feed in the Control tab of OctoPi and I get no error message

What did you already try to solve it?

To setup the webcam I used the following guide:

I used the following parameters "-r HD -f 20" which should be used with my cam according to the camera guide.

Have you tried running in safe mode?


Systeminfo Bundle (11.4 KB)

Additional information about your setup

OctoPrint 1.7.3, OctoPi 0.17.0, Anycubic Vyper, browser: Chrome, operating system: Win 10.
According to the guide I followed camera_http_webroot= should be set to ''./www" (so two ' instead of one "), I assume this is incorrect and it should it be one "?

No one has any input regarding this at all??

What are the settings for the webcam under

OctoPrint Settings -> Features -> Webcam & Timelapse ?

These are the settings:

The URL is empty and the guide never mentioned anything about this. But I think per default there was an URL but I don't remember what it was so right now that field is just empty

Try with in Stream URL:


Side Note:

This is for older OctoPirnt versions.

Recent versions like 1.9.0 onwards work different.

Tried it but it didn't work so I upgraded to Octoprint version 1.9.1 and now the webcam stream works in Octoremote mobile app using this URL http://MYIP/webcam/?action=stream

Is it possible to set up a WiFi webcam to Octopi or does the webcam have to be directly connected to my Octopi unit?

1 Like

WiFi cams should work too. You have to use the URL/IP address of that cam then.

But not all cams like to cooperate with OctoPi/OctoPrint

That's good news cause I much rather use my WiFi cam instead due it having a lot more features and better quality. I have a TP-Link Tapo C200 and I found a guide to set up a stream using VLC Player.
The URL i used was in the following format: rtsp://username:password@MyIP/stream1
This worked fine in VLC and I could see the stream but when using the exact same URL in Octoremote it would not work.

OctoPrint (& I suspect all 3rd party apps) don't support RTSP streams. Also, in the browser, they don't allow embedding the username & password in the URL as it is not secure, so even if it was mjpg, you wouldn't be able to get through the authentication.

If the camera provides a plain mjpg stream, then that works otherwise you're out of luck with that camera I suspect. Perhaps someone else has a solution they came up with.

That does not sound promising but thanks for the info. I was able to find the datasheet for my cam and the supported protocols listed are:
and unfortunately MJPG is not listed as one of them, and I guess none of the others work?

you list a number of protocols and offcourse MJPG is not listed there because MJPG is a format not a protocol. it stands fo Motion JPG or in other words it sends a jpg photo for each frame in the video. that's why it uses so much resources. it would be nice if we could use something more modern like mp4, h264 or h265.

Omit the "-r HD" until you get things running.

Your camera supports MJPEG, YUY2 and H.264 output formats. So either of the former will work with the new stack.

Have you tried the new camera-streamer?