WiFi Connection Issue

What is the problem?

After some time, the octoprint "disconnects" from the network. I can see it connected to the router, but I cannot access the UI, nor ping or SSH the RPi 4. If there is a print running it keeps printing normaly, I just lose all control.
It occurs randomly and I haven't managed to find a trigger for this issue.

What did you already try to solve it?

I tried connecting from other devices on the network (WiFi or cable connected) and nothing. I tried disabling all firewall settings on my pc, but the problem seems to be in the RPI.
I deactivated most of my plugins and I am currently running only the most basic setup. I tried running prints of of SD card and used OctoPrint just for monitoring and Webcam stream.
I am using the original RPi power supply and never had any issues with undervolting.

Have you tried running in safe mode?

No, will be trying that next

Systeminfo Bundle

octoprint-systeminfo-20240501115818.zip (25.4 KB)

Additional information about your setup

Raspberry Pi 4 Model B Rev 1.2
OctoPrint Version 1.9.3
OctoPi Build 2023.10.09.151442 with "webcamd", based on OctoPi 1.0.0
Webcam Foscam W81 - 8MP Ultra HD webcam- Foscam
PSU - Official EU Raspberry Pi 4 Power Supply (5.1V 3A) | The Pi Hut
Printer is Prusa MK3S+

I believe this is a base OS issue and there are multiple topics in this forum that discuss it. Use the search icon at the top and search for "WiFi connection". A couple that might be worth reading:

There are also a couple of plugins that might be useful.

You can also check the Raspberry Pi forums for additional information / remedies.