WiFi Connectivity Issues


Hi all,

I'll start by apologizing way in advanced since I am sure this question has been asked many times before, but ive spent hours trying to get my raspberry pi 3 model B connected to my home wifi.

All advice I find on line is a little too technical for me to full understand why im doing things the way I am. I dont have any experience with this system.

I bought a prusa mk2s used from a guy who only used this for 9 hours. I am not sure if he got Octopi up and running but I completely wiped the SD card, etched in the octopi img file through my terminal and changed the supplicant file for my wifi settings. When I plug the SD card and power it up, I dont get wifi connectivity. The green light very infrequently blinks green and I cannot find the pi's IP address anywhere.

To make sure I etched the sd card correctly, I hooked the pi up to a monitor and plugged in ethernet. Connected right into octio pi after finding the IP address. I tried doing the same and my last like of code says I am able to open a web browser with the following addressed but nothing is listed and it wants me to login with my octopi login which I havent set up....

Are there any suggestions in layman terms?


It's subtle, but if the Welcome screen locally on the Raspi after logging in doesn't display at least one line there this means that your network adapter(s) don't have a bound IP address. The likeliest cause would be some sort of mistake in your microSD's /boot/octoprint-wpa-supplicant.txt file's settings.



Thanks for your response! This is my terminal after logging in. Everything seems like it is working besides the wifi but that could be my shear lack of understanding.

Let me know what you think!


I see that this time I get a login web browser but when I try to pull up the octopi website listed, the server cant be reached because there isnt a valid IP


Run an ifconfig from there and you'll see that if there's a section for wlan0 then it doesn't have the word RUNNING in that first line. And there won't be any IP addresses shown in the next couple of lines. Meaning: it's not connected to your wi-fi. Follow this new link:


As predicted, the RUNNING flag isn't present in the wi-fi paragraph of ifconfig's output. It means that this didn't work out. Make sure to reboot after making changes to that file. Feel free to copy/paste the contents here for us to verify.

Remember that the country code has to be in uppercase. Both SSID and password are case-sensitive. Classic errors from new people are to forget to remove the pound signs which are involved in that network paragraph.


Ok, I am a relative noob to wireless but, dumb question.
In the snapshot you indicate the SSID is "Angsty Bohemians 5GHz" so I wonder if 'spaces' are allowed in the name???
A quick google says some 'special characters' are allowed, but the source I was looking a did NOT include the space.

Just a thought.



worth a shot! I ran a wifi scan to see how my pi displays it but i can only view about 3 before the scroll limit prevents me from seeing any more.


Upon a quick search it definitely seems to be the issue here! I'll need to configure some lines of code to allow the pi to read spaces in the SSID


Just replace the spaces with "_" (underscores)



Personally, I know that my own apartment complex is full of SSIDs which contain spaces. But does that work for all devices? (I'd rather not be the one to find out.) So I tend to use a "This-Is-My-SSID" sort of naming. In fact, remember that in a busy place, alphabetical order matters. You can see how macOS sorts them. It's easiest if yours shows up without having to scroll or to have to click a "More" link at the bottom.

One thing I did note is that you have two identical lines for the country code. Comment out the second one.

Another question would be if your SSID is hidden on your router. If so, another variable is needed in that network paragraph.


I DID IT!!!!

So, I went home and finally found out why my keyboard was messed up. I then could run the scanning wifi command to see what names it could see. I saw the 2.4GHz version of my wifi instead of the 5GHz so I just used that with spaces. I kept the spaces in at first without modifying but I took out the second country definition line of code and it worked! flawlessly. I am now testing curaengine through cura itself now!

Long story short, could have been the double country defining pieces of code or the fact it never did see the 5GHz SSID


That's greta! Please mark this as solved then


Raspbian out-of-the-box is set to assume that you're in England. You might want to visit sudo raspi-config to set the localization features to set your keyboard to be that of your own country. I note that some of the characters don't map correctly when the country code is wrong there.