X&Y axis move beyond print size at beginning of print

What is the problem?

just finished installing and configuring octoprint and klipper onto my Anet A8 Plus printer with a new SKR 2 board. I have almost everything working to the point of trying a simple cal cube print for the first time. All axis move in the correct direction from the control panel but can go past max and gring belt, I have checked my printer size setting in the config, octoprint as well as my slicer (superslicer). They all match with X:300, Y:300, and @ Z:250 due to wire length limits. When i hit begin print all seems well untill both X&Y try moving beyond the 300mm max limits and begin grinding the belts. Z axis seems fine.

What did you already try to solve it?

Confirmed my config, slicer, and octoprint all have the same bed dimensions, origin at 0,0, and my position min/ bounding box goes X: -30 to 300 and Y: -8 to 300

Have you tried running in safe mode?

yes

Did running in safe mode solve the problem?

no

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20221203172936.zip (212.5 KB)

Additional information about your setup

Anet A8 Plus printer
BTT SKR 2 board
Octoprint 1.8.6
Klipper
Superslicer 2.4
xyzCalibration_cube.zip (68.8 KB)

Hello @Saltzilla !

It would be quite helpful if you would have done these:

You also may share a gcode file. (You can zip it and upload it with your next post)

updated original post.

I wrote next post, because readers always get the first unread post shown.
So when you edit the first post, readers have to scroll up again.

Ok, this is a short thread, but imagine on a 20+ post long thread :wink:

To your issue:

When you homed the printer and when you then move the print head 100 mm in X or Y (via the control panel of OctoPrint) does it actually moved 100 mm?

ahh gotcha. It's been a while since I've actually used forums. So when I move X 100 after homing it actually moves roughly 250mm. I have a feeling I've missed a calibration step somewhere...

After I've seen that the gcode is ok, I suspected this.

Guess I’ll be calibrating e-steps tomorrow and updating everything. Thanks for opening my eyes up to that easy oversight. Smh

1 Like

So got around confirming my config microsteps and rotation distance are correct at 16 microsteps and rotation distance of 32. Also I tried switching superslicer g-code flavor to marlin like klipper documents said to do. the issue still persists. Also measured the movements with a caliper today and every 10mm control panel press for X moves it 25mm. Seems to be an octoprint issue for me

finally got the printer to move 10mm in all directions after drastically changing the rotation distance of all axis in my config file that was provided from Klippers site. X from 32 to 80, Y from 32 to 79, and Z from 8 to 16. Will try actual prints tomorow to confirm everything.

1 Like

I recommend (next time) you have issues with Klipper, you may consult the Klipper board:

:wink: