Another under voltage problem with Rapsberry Pi 3B+

What is the problem?

Still getting under voltage warnings after using a new official Raspberry Pi power supply 5.1 V, 3A.
I have the Raspberry Pi webcam Maker Hawk IR attached. Printer is the Anycubic Viper. No further hardware. What can I do? Is it possible to switch off the warnings?

What did you already try to solve it?

New power supply, see above

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.8.4. Update not possible due to low voltage warning.

Have you tried without the cam?

Unplug the camera. Pi 3B+ only can supply a TOTAL of 1.2A over the USB ports. If it runs fine then, the USB camera is pulling too much power

The other problem is the printer may be sucking some power through the cable, I would try with the printer disconnected, if this fixes it then the cable needs to be modified to remove the power wires.

Then also try this:

I have several Pi 3s with dates on them from 2015 onwards. Some of these complain with the low power warning and some dont - and this is with me swapping the Pi 3 out completely using the same setup - and even the same SD card. Recently I've setup a FabScan 3D scanner, and only on my third identical Pi 3 did I get no complaints due to low power - the only things powered by the Pi 3 were the fan and a V2 camera. I always use an official Pi PSU. In fact I even tried upping to 5.3 volts from a 20 Amp PSU to see if that would help (the warning is about voltage, but I suspected that it may be affected by current), The same thing happened. Even when I set up a MotionEye Server with a single IR camera. In fact, it seems for me anyway, that some of my Pi 3s are more susceptible than others. I had the same issue with OctoPrint - used a Pi 3 with an offical PSU, and had the same low power warnings, so I switched to using a Pi 4 (2GB) to run my OctoPrint server, this is with an official USB C PSU and I have had no problems with it.It does use a USB camera though rather than using the CSI on board parallel connector.

Just reading through this website on low power, and the last comment is worth looking into (Oct 2021 - not sure if this is still relevant. It mentions Octoprint 1.6 being worse than 1.5 for this problem - maybe the changes between the 2 ISOs cause another issue (The 2 ISOs may include different boot/linux/kernel versions as well as Octoprint changes).

https://pimylifeup.com/raspberry-pi-low-voltage-warning/

"So if you are experiencing the issue with Octoprint an tried all kinds of Poweradapters including the official one like me, try this: Using WIN32 to flash the ISO to a sd card might cause some issues instead Reinstall Octoprint Using the official Pi Manager, this uses also the 1.5 build, not the 1.6 build octoprint. This solved my never ending search for a solution"