Cannot connect to printer

What is the problem?

Octoprint stopped connecting to my Ender 5 plus last month after it had always worked flawlessly before, I thought maybe it needed an update, but after update still did not connect.

Changing monitoring state from "Offline" to "Detecting serial connection"

Performing autodetection with 0 port/baudrate candidates:

Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected."

Changing monitoring state from "Error: No more candidates to test, and no working port/baudrate combination detected." to "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)"

Ever thought you’re going crazy and turns out it’s too late?

I've been on it for more than a week without success, I've read all the posts I could find, but I'm really stuck.

I understand that the Octoprint can’t see the printer, thus cannot connect, the question is why?

Is there a port conflict or something?

I can’t imagine with all the below that it’s the USB cable or the board, all is ok, didn’t drop it or anything, just stopped one day, maybe Covid?

What did you already try to solve it?

  • Bigtreetech SKR1.4 turbo board with 4xTMC5160 SPI mode and S42B closed loop x driver => nope
  • Same setup with TMC2209 UART => nope
  • Tried 4 different micro-SD cards => nope
  • Tried 3 different USB cables => nope
  • Tried Octoprint in safe mode => nope
  • Tried with laptop usb C power supply 5A => nope
  • Tried Octoprint version 2021-01-11_2020-08-20-octopi-buster-arm64-lite-0.18.0 => nope
  • Tried Octoprint version octopi-buster-lite-0.17.0 => nope
  • Tried Octoprint version octopi-buster-armhf-lite-0.18.0 => nope
  • Swapped back to original Creality v2.2 (8 bit) silentboard => nope
  • Updated Creality firmware Ender-5PlusBLTouch_0904_V1.70.1 BL => nope and nope
  • Tried Octoprint serial settings with and without Wait for start on connect => nope and nope
  • Tried with and without Request exclusive access to the serial port => nope
  • Tried with and without Enable automatic firmware detection=> nope
  • Tried raising Initial baudrate detection pause to 2 or 3 seconds => nope
  • Tried adding dev/ttyAMA0 => nope
  • Tried adding dev/ttyS0 => nope
  • Tried adding dev/ttyUSB => nope
  • Tried baudrate 115200 as well as auto => nope
  • Tried without Pi Cam connected => nope
  • Tried all NL and GB locales => nope
  • Tried Raspi-config serial on/on, off/on, on/off => nope, nope and nope
  • Tried Raspi-config webcam off and on => nope and nope
  • Tried tty port cleaner plugin => nope
  • Tried firmware detection plug in upgrade => nope
  • Tried rpi update (and immediately after, back to safe version) => nope and after still nope
  • Tried apt-get upgrade => nope
  • Tried apt-get update => nope
  • Tried apt-get update -missing-fix => nope
  • Tried chmod 666 /dev/ttyS0 and USB, USB0, USB1=> noperdenopenope
  • Tried chmod 777 /dev/ttyS0 and USB, USB0, USB1 => still noperdenopenope

Printer connects with PC and Pronterface without problems in all configurations, motherboards and USB cables, Raspberry Pi? (you know by now,…..yeeeaaahhh => nope)

Edited above so it can be read normally

Hello @Mace !

Connecting to the printer is no network issue...

Hi, could you please move it to the appropriate section?
I didn't know where to put it?

I already did. It's just Get Help.

Duhh, thanks!

1 Like

Additional information about your hardware (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
• Running Win10k, using octopi.local on Google Chrome web browser, nothing special
• Raspberry Pi 4 8Gb with OEM Raspberry power supply
• 128Gb Sundisk microSD (also tried 8Gb, 16Gb, 32Gb)
• Creality Ender 5 plus with Meanwell SE-600-24 power supply, Biqu116-A2 heatbed mosfet, OEM BLTouch v3, BTT S42B Closed loop driver, Marlin

Can you connect to the printer via Pronterface?

Yessir, no problems whatsoever with pronterface

Both motherboards SKR1.4 and Creality board connect fine to pronterface

Have you tried to connect a HDMI TV/monitor and USB mouse and keyboard to the Pi to check if the USB works.

Yes, HDMI works, I’ll check the usb tomorrow with a mouse, but the creality board lights up when connected to the pi via USB

So, did you power the printer on?

Yes ofcourse, tried with and without power, all logical diagnostic steps, something screwy is going on

I was surprised when you said, that the printer display lights up when you connected the printer to the Pi's USB. It should be lit when the printer is powered on.

yeah, powerbus is working, I'm suspecting irq or port conflicts or something like that, but who knows

Have you already tried this: ?

Ah, so think there is a significant voltage drop due to drawn current by the printer motherboard causing hardware not recognising bus signal
Interesting, I'll try it

Sounds like you know what you're talking about, we just operate on 'it fixes many things, most of which are unexplained'...

No, I just break a lot of things :partying_face:

1 Like