Cannot connect to SKR v1.3 board

What is the problem?

I cannot connect to my SKR v.1.3 board. It will time out after a bit. Printer will move axis via marlin menu.

What did you already try to solve it?

I have tried both a Pi v3B and a Pi 4b. Have replaced USB cable and updated both Marlin and Octoprint. Marlin is v 2.0.9.2 and the Pi is running 1.70

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No change

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-logs.zip (498.8 KB)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Marlin is v 2.0.9.2 and the Pi is running 1.70. The printer is a Hypercube 300 core x/y, the browser is Chrome and OS is MacOS 11.6

Hello @roontoon !

You may try more different USB cables. Those with ferrite beads at the ends are for data transfer.

You may try this:

Try to connect to your Mac with Pronterface

Hello,
I saw numerous errors reported with plugins from runs yesterday, no tests with a printer connected before noon today. The log does not contain a run with Safe Mode enabled.
I used grep --text -F "octoprint.util.comm" octoprint.log to condense the connection-related lines from the log, for some strange reason grep treated the .log as a binary file and I had to force it into text mode.

OctoPrint tries the serial port on 7 different baud rates and gets no handshake.
It might help to look what the kernel sees of the connection.
For this please

  • ssh into the pi
  • pi/raspberry
  • unplug the usb cable
  • type into the console: sudo dmesg -w
  • hit enter 2 or 3 times to make a visible empty line
  • now plug in the usb cable
  • wait a few seconds until there is no more new text in the console
  • copy the lines that appeared after plugging the cable and
  • post them here

Thanks for the help. Here is the log.

[  109.521681] sd 0:0:0:0: [sda] Asking for cache data failed
[  109.521690] sd 0:0:0:0: [sda] Assuming drive cache: write through
[  109.522803] sd 0:0:0:0: Attached scsi generic sg0 type 0
[  114.159742]  sda: sda1
[  114.167419] sd 0:0:0:0: [sda] Attached SCSI removable disk
[  261.669488] usb 1-1.1: USB disconnect, device number 6


[  304.981898] usb 1-1.1: new full-speed USB device number 7 using xhci_hcd
[  305.119911] usb 1-1.1: New USB device found, idVendor=1d50, idProduct=6029, bcdDevice= 1.00
[  305.119931] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  305.119948] usb 1-1.1: Product: Marlin USB Device
[  305.119964] usb 1-1.1: Manufacturer: marlinfw.org 
[  305.119979] usb 1-1.1: SerialNumber: 0E00A01CAF3C8CA75CFDC539F50020C3
[  305.129026] cdc_acm 1-1.1:1.0: ttyACM0: USB ACM device
[  305.134062] usb-storage 1-1.1:1.2: USB Mass Storage device detected
[  305.137761] scsi host0: usb-storage 1-1.1:1.2
[  306.154835] scsi 0:0:0:0: Direct-Access     Marlin   SDCard 01        1.0  PQ: 0 ANSI: 0 CCS
[  306.156798] sd 0:0:0:0: Attached scsi generic sg0 type 0
[  306.163221] sd 0:0:0:0: [sda] 245760 512-byte logical blocks: (126 MB/120 MiB)
[  306.164689] sd 0:0:0:0: [sda] Write Protect is off
[  306.164708] sd 0:0:0:0: [sda] Mode Sense: 00 00 00 00
[  306.172168] sd 0:0:0:0: [sda] Asking for cache data failed
[  306.172188] sd 0:0:0:0: [sda] Assuming drive cache: write through
[  306.224263]  sda: sda1
[  306.231192] sd 0:0:0:0: [sda] Attached SCSI removable disk


The kernel complains of no errors, sees a product, manufacturer and even a serialNumber. On some level the connection seems to work.

Does your printer have a SD card inserted? If so, when you take it out, do you see any change?

Tried that. No change.